Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am given a guest ssh login (with username and password) to a remote server. How can I mount a directory on the remote server locally on my machine? Both remote server and local machine are running Ubuntu. And I don't have permission to change configuration on the remote server.

Please let me know if you have any idea.

Thank you.

I tried http://askubuntu.com/questions/46183/how-to-map-a-network-drive

The output of '% smbclient -L //10.22.123.45' is

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]

    Sharename       Type      Comment
    ---------       ----      -------
    print$          Disk      Printer Drivers
    IPC$            IPC       IPC Service (mobmm-ubuntu22 server (Samba, Ubuntu))
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7]

    Server               Comment
    ---------            -------
    MOBMM-UBUNTU16       mobmm-ubuntu16 server (Samba, Ubuntu)
    MOBMM-UBUNTU22       mobmm-ubuntu22 server (Samba, Ubuntu)

    Workgroup            Master
    ---------            -------
    WORKGROUP            MOBMM-UBUNTU16

and then I do 'sudo mount -t cifs -o username=guest //10.22.123.45/MOBMM-UBUNTU22 /mnt/mylocaldirectory '

I get this error:

Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I tried another name 'MOBMM-UBUNTU16', same result.

And when I do 'sudo mount -t cifs -o username=guest //10.22.123.45/IPC$ /mnt/mylocaldirectory'

I get

mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs
share|improve this question
    
Does this help? askubuntu.com/questions/46183/how-to-map-a-network-drive –  sabrefresco Apr 19 '13 at 18:42

1 Answer 1

up vote 1 down vote accepted

You should be able to mount using sshfs. Try this from the local machine:

sshfs -o idmap=user $USER@1.2.3.4:/remote/path /local/path

See here for more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.