Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Youtube website is working fine for me, i.e, I can browse the site fine and search videos. But when I click on any videos, I just get blank page.

For example, let's say i open youtube and search 'LAN Party: GTA IV PvP', i get the search results with the list of related videos but when i click on any video, I just get a blank page with the video url in the address bar 'http://www.youtube.com/watch?v=p9ZsXFAiF8M'.

For now I'm changing the url to 'http://www.youtube.com/v/p9ZsXFAiF8M' to watch the videos but I need a permanent fix.

This issue is there on Chrome and also on IE. This is my home connection and my roommates pc on the same connections loads the pages fine.

share|improve this question
    
try deleting youtube's cookies. Refer to one of my previous answers for help on how to do it. –  Cybertox Apr 22 '13 at 4:52
add comment

1 Answer

Does it happen when you try youtube in incognito mode?

If so, try clearing the cache and cookies. If that doesn't fix it try disabling each extension you've installed, sometimes chrome extensions can cause problems with page rendering(eg:-adblock).

If that doesn't do it, turn off any flags you might have enabled in chrome://flags, or go to chrome's properties and insert "--no-experiments" without quotes in the target box to disable all flags:

enter image description here

If it still doesn't work, you should try installing flash externally from this site and then disabling the built in flash by going to "chrome://plugins", clicking on details in the right hand side of the screen, then navigating to Adobe Flash Player and disabling the plugin whose location is something like "Chrome\Application\26.0.1410.64\PepperFlash\pepflashplayer.dll ". Make sure that there is another entry under Adobe Flash Player that remains enabled.

enter image description here

If the problem persists, try reinstalling chrome. If you have sync enabled, it shouldn't be too inconvenient.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.