Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After I install Steam it gives me an error and say "steam.exe has been deleted but it's still there", then when repairing it says that I don't have permission to access steam.exe/steamtmp.exe

I'm running Windows 7 Ultimate Signature Edition, it's a fresh install and not an upgrade.

Update: Solved the problem with a mix of all the suggestions. What I did was:

  1. Install it.
  2. When the update window open I close it immediately.
  3. Go to steam.exe, proprieties, compatibility > XP SP3 mode.
  4. Open it a let it update, after every update close it and run it again to let all the updates download.
  5. When it doesn't update anymore go to steam.exe and unchecked the compatibility mode.
  6. Start it normally with Win 7.

After that it worked with no problems.

share|improve this question
    
Steam has worked fine on Windows 7 x64 for several weeks for me. Just so you know that it can work...I have no idea how to fix your particular problem. –  davr Oct 21 '09 at 22:20
    
It's kind of weird because it's the only application that isn't working for me. I have thing like photoshop, dreamweaver, office, etc. all working without any problems. –  octa Oct 22 '09 at 21:07

5 Answers 5

up vote 1 down vote accepted

Is this error when you try to run it?

Go into properties, compatibility, check Run as Administrator. If that doesn't work, set it to XP SP3 compatibility mode.

Steam is working on 7 fine for me, but I've had to do this with several apps.

share|improve this answer
    
I did that yesterday, then a window saying that compatibility mode was not recommended appeared and the settings reset by their own. –  octa Oct 21 '09 at 20:55

Try to take ownership of the steam.exe (or the whole folder) it sounds like you may have lost permissions to the file.

share|improve this answer
    
I took ownershpo but keeps saying that steam.exe was deleted but it's still there, after it says that it tries to re-install and there it says that I don't have permission, again. –  octa Oct 21 '09 at 20:36

In steam folder remove everything but steam.exe and steamapps folder then run steam.exe file, if it doesn't help or you have no games installed try to completely remove steam directory and reinstall it from scratch.

share|improve this answer
    
I installed it from scratch, since my Win 7 installation was also from scratch. The problem is that when running for the first time when it's updating after hitting 20% it says that steam.exe was deleted etc. so when running it again it automatically re-install reseting the ownership settings but it gave an error not finishing the installation. I hope that from tomorrow, that it's the official release on 7, steam gives the complete support for it –  octa Oct 21 '09 at 21:06

I had a similar problem with another program (java in this case). The thing that evetually worked was after uninstalling it and deleting all left over files manually to re-install it in a different path. If I used the same path again, same problem, but when selecting a different path it worked.

share|improve this answer

I had the same problem, I checked every where none of this stuff worked I did this:

Uninstalled it, Reinstalled it and when i got the error message click OK, you should still have a steam.exe icon on your desktop from the install. Reboot your system into safe mode and run the steam.exe icon on your desktop. Everything updated and my steam is now working again. I am now installing modern warfare 2...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.