Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Clients with exceptionally high resolution displays are able to scale the size of their own text and icons to ensure they remain usable. However when using Remote Desktop this setting does not persist through the target machine and so the text and interface is very small and hard to use.

The Remote Desktop client allows the user to specify the resolution that they wish to use on the target machine, but it does not have an option to enable interface scaling. Choosing a lower resolution simple creates a smaller window. Setting the scaling directly on the target OS would force the setting for all other user, who may not want it enabling.

Is it possible to set a lower Remote Desktop resolution whilst keeping the window the same size (up to full-screen) so that the display is artificially scaled?

share|improve this question
    
This isn't a duplicate, and there isn't an answer in that link - at least not for the detailed question. Simply changing the resolution of the machine you're connecting to doesn't solve the problem. It just makes the RDP window smaller, and text in it is just as tiny. There still doesn't appear to be a way to make the text more legible when running bootcamp/a windows VM on a MBP w/ retina display. –  dennis.sheppard Jul 21 at 15:04
    
Dennis is correct, this is not a duplicate. The actual question being asked is how to scale the display inside the Remote Desktop window. If you're using a Windows machine with a high resolution (e.g. Surface Pro 3) you can set a scaling option in the resolution settings that makes text and icons larger. However this setting does not translate to the machine you're viewing so you end up with an unsuitably small interface. The duplicate-linked question does not address this at all. –  Ian Sep 15 at 16:43

1 Answer 1

Yes you can,

Easy answer #1, lower your screen resolution before connecting to the server in question. Problem solved!

More difficult but more interesting way #2:

To connect an rdp session in a maximized window:

Create an RDP file at the resolution that you want, by opening mstsc.exe and setting up the name of the computer that you are connecting to and choosing a resolution OTHER THAN FULLSCREEN on the display tab, I would suggest a 16:10 resolution like these:

This is a list of common screen resolutions with the 16:10 aspect ratio.

Name Dimensions
WXGA 1280×800
WXGA+ 1440×900
WSXGA+ 1680×1050
WUXGA 1920×1200
enter image description here

On the General tab click "Save as". Save the .rdp file somewhere you will be able to find it later.

Now, Open this .rdp file in notepad - (I suggest opening notepad first and then dragging and dropping the file onto it)

Add the following line to the bottom of the file:

smart sizing:i:1

From Notepad's file menu, choose save and close. Smart sizing allows you to stretch your rdp session while connected, while keeping the same resolution. More on Smart sizing here.

Double click on the rdp file that you have altered and your session will open in a regular desktop window, but you can now re-size that window by dragging the corner! This can make for some strange looking rdp windows:

enter image description here

Now, you could just maximize that window, but you can also get it to switch to fullscreen by using the CTRL+ALT+Pause/Break, but you can't do that because you are using a MAC and are missing the keyboard pause/break key that you need to make your session go fullscreen.
FYI: The VIRTUAL KEYBOARD inside of "ease of access center" inside of Control Panel (all view). Will also Still not let you go fullscreen.

So if you must have fullscreen, you will need to download and install Autohotkey and create a script like the one here: http://www.rodolforodarte.com/2011/10/remote-desktop-won%E2%80%99t-go-back-to-full-screen-part-2/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.