Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know the system interrupts topic is pretty common with varying solutions but I had a question about how to implement a solution in Windows 7 the way I did in Ubuntu 12.04.

Background:

  • Bought an ASUS K53SV model laptop in May 2011 and it worked great until a couple of months ago when the CPU started to act up.
  • After using a Latency checker, found the culprit was ACPI.sys
  • Tried a number of solutions until the computer became unusable
  • Installed Ubuntu 12.04 over everything
  • Problem persisted with kworker taking up CPU
  • Fixed the issue by following the instructions here
  • GPE04 was acting up so I disabled it and things were back to normal

TLDR:

I need to have Windows 7 running for work though and I was wondering if there was a way to find the specific interrupt and disable it the same way I did in Ubuntu.

I have a suspicion that the interrupts are caused by the dedicated NVidia 540M GPU since I had trouble getting it to work in Ubuntu and video crashes became more common around the time the issues first started. I've tried almost everything on the web and the issue persists and I imagine it's something hardware related.

EDIT:

I've already tried reinstalling Windows, fan speed and updating the BIOS. I'm asking more about disabling interrupts in Windows 7, I've accepted that the main problem is not solveable.

share|improve this question
    
This doesn't answer your question, but it may render it moot: Have you re-installed windows and verified that the problem still exists? Have you tried updated drivers for your video card? –  G Koe Apr 21 '13 at 5:49
    
I've reinstalled windows multiple times and the problem persists. Also tried latest and multiple video card drivers. –  Erofire Apr 21 '13 at 16:34

2 Answers 2

up vote 2 down vote accepted

I used to have the same issue, although my notebook (Asus K53SC) was about 20 months old when the problem arose. Symptoms were the same: ACPI interrupts eating one CPU at 100%, the fan is constantly running at what sounds like maximum speed. I've installed Ubuntu and the problem was there too (GPE06 in my case).

The root cause of the problem was... dust! I've disassembled and cleaned my notebook and interrupts are gone both in Windows and Ubuntu.

Look at what I found after disassembly: enter image description here

Compare to cleaned: enter image description here

Disassembly guide

share|improve this answer
2  
Thanks a ton, this actually worked! The guide was especially helpful. –  Erofire Dec 16 '13 at 2:27

I saw other users with an ASUS laptop and the ACPI.sys DPC issue is caused by CPU throttling to avoid overheating.

Use Speedfan to increase the CPU cooler fan speed. Also call the ASUS support for an updated BIOS which includes a better fan management.

share|improve this answer
    
Thanks a lot for the link. I've tried modifying the speed of the fan but it seems impossible on this laptop. It shouldn't matter though because the fan is constantly running at what sounds like maximum speed. I've tried updating the BIOS, no changes. ASUS won't support me because I've installed my own version of Windows 7 as the recovery disks did not work. –  Erofire Apr 21 '13 at 16:36
    
try this tool: sdrv.ms/P6RKKe –  magicandre1981 Apr 21 '13 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.