Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I dual boot Ubuntu and Windows 8. Ubuntu is 1 hour ahead, so I set it to 1 hour back and then when I next log into Windows 8, the clock is 1 hour behind. If I then set it forward in Windows 8, it is 1 hour ahead in Ubuntu..

My BIOS clock seems to be working, but how could this be happening?

share|improve this question
    
Which timezones are selected in Ubuntu and which one in Windows. Do these differ? –  Hennes Apr 21 '13 at 10:57
2  
Related reading. –  ta.speot.is Apr 21 '13 at 11:13
    
@Hennes - Nope! –  TomRichardson Apr 21 '13 at 14:14
    
Set Ubuntu to use local time instead of UTC. –  fixer1234 Oct 21 at 4:56

1 Answer 1

The default configuration is for Windows to display the selected time zone time and store it in the BIOS, but Ubuntu stores the UTC time in the BIOS and displays the selected time zone time.

There is some hidden setting to have Windows to save UTC time in the BIOS but it doesn't work quite right, it's not recommended to use it. There is a setting for Ubuntu to store the selected time zone time in the BIOS, that works fine.

Edit /etc/default/rcS and change the utc line to UTC=no.

If you do the installation in expert mode it's actually asking you if you want the BIOS time in UTC or not.

share|improve this answer
1  
Iḿ sure this is the correct answer. See also this Ubuntu help page for more details, and it also contains a guide how to make Windows use UTC BIOS time. –  Stefan Seidel May 2 '13 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.