Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use the US and United States-International (INTL) keyboard layouts, since I occasionally need to type characters not normally found in English. I rarely use the INTL layout intentionally. However, Windows is constantly switching to it. I am definitely not physically pressing the Win + Space key combination to switch layouts.

From what I can tell, this happens while I'm using the touchpad (Synaptics) on my laptop. I have problems with the Synaptics drivers interfering with games by briefly removing focus from them when I scroll, and occasionally sending a Ctrl keystroke, so it would not surprise me in the least if Synaptics is responsible. It never seems to happen while I'm typing, only between typing.

Edit:

It's probably important to mention that I've been having this problem since the days of XP Pro. I've never used anything besides x64 in the time since I started using multiple keyboard layouts. Most of my OSes come from TechNet or MSDN (retail, US), but I've also used betas, previews, and OEM releases. I tend to use the Pro/Ultimate versions. I've had the problem even after disabling the keyboard shortcut if I recall correctly, but it's been a while since I've done that; it's really not an option in Windows 8 anyway, since the taskbar isn't always visible.

I use Linux quite a bit. I want to say I've set the equivalent shortcut in GNOME to Alt + Shift and didn't have the same problem, but it's been a while. I still cringe whenever I hold Alt and Shift together, and I often repeat Alt + Shift if I perform an incomplete shortcut that uses those two keys out of habit. I'm pretty sure that keyboard shortcut isn't the issue.

share|improve this question
    
I have the same problem on my HP Envy 15 laptop, which also has a Synaptics touchpad. – Mas Jun 9 '13 at 11:31

There is a Shortcut which switches through your installed languages:

Left Alt + Shift

It may be the problem. Right-Click the Language Toolbar in the Taskbar and go to Settings>Advanced Settings / check the Shortcut Settings there.

share|improve this answer
1  
This is Windows 8. None of that is relevant. See the original question for the current keyboard shortcut. – Zenexer Apr 21 '13 at 19:49
    
Well i use Windows 7 and 8.... the Shortcut does in fact change the layout on both versions – M.Bennett Apr 21 '13 at 19:52
    
It will only change the layout on Windows 8 if you are using multiple languages (which I am not). – Zenexer Apr 21 '13 at 19:53
    
>>> I use the US and United States-International (INTL) keyboard layouts – M.Bennett Apr 21 '13 at 19:54
    
Then you have some weird configuration, because that's not how Windows 8 works. See: Google (Anyway, it's irrelevant, because it doesn't work with my configuration.) – Zenexer Apr 21 '13 at 19:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .