Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having problems with my PC, first of all I started getting Disk Read Errors when trying to boot from my SSD. However I usually was able to restart my computer a few times and it would eventually boot up. However as time went on (about 1 week heh), it took longer and longer to get through to boot. One day it just wasn't having it and I looked in to it and ended up having to reformat my harddrive. I used a live version of Ubuntu to do this and I before completely formatting it, I went on to the SSD and transferred all my games over to my other 1.5tb harddrive so that only Windows was left on the SSD. I then tried ghosting Windows over to my 1.5TB harddrive and it failed in the process, I got a few logical errors and ended up having to abort the process.

Instead, I took the windows files from SSD and put them in to a folder on my 1.5TB Harddrive. Then I tried formatting/reinstalling windows from a disc and it wouldn't load up either, first of all it said disk read error and eventually it got through, however once I got past the Windows splash logo, the screen went black for 40 mins until I restarted it. Then I got the error message "BOOTMGR is missing" so I tried doing installing it through USB. After several attempts I got to the installer, however when I clicked through the prompts, it got to a screen where it said "Windows is preparing setup" or something along those lines. It hung there for over an hour and eventually it got to the screen where you are meant to choose where you would like to install Windows on to. However there was nothing listed.

I turned my system off and checked all the connections/switched sata ports etc. w and then it successfully let me get passed the "Windows is preparing setup" and it listed my SSD and other Harddrive. I then tried installing it on to my SSD and got the error code 0x80300024. I read up on it and I found a forum post saying that it worked for someone once they disconnected all devices except the device you wanted to install Windows on. So I did so and to my surprise it worked. I booted in to windows and began installing drivers etc. I restarted a few times during this and then remember I was still missing my 1.5TB harddrive, I powered off and connected it up. I then tried to boot back in to my SSD and I got the disk read error message again. Frustrated, I tried all the connections again with no success. So here I am now, wondering if anybody could help me on what I should do next. :)

Thanks for reading

share|improve this question
    
Is the drive that worked showing in the BIOS as your first boot device? –  AthomSfere Apr 21 '13 at 15:05
    
SSD is showing as first boot device –  3lliot Apr 21 '13 at 15:12
add comment

1 Answer

HDD errors are sneaky. If a drive behaves errornously independent of OS and BIOS settings, it won't get better. Save yourself the headache, back up ASAP, and get a replacement drive.

share|improve this answer
    
The thing is I was able to boot on to a fresh version of the OS until I connected the 1.5TB harddrive, so are you sure I should give up? –  3lliot Apr 21 '13 at 15:27
    
You could try the misbehaving in a different computer, if you have one, to rule out a faulty controller, but if your optical drive is fine and other drives are fine, I wouldn't put too much hope in it. If the drive is really bad, at least trying it in another computer will perhaps confirm it. –  fuero Apr 21 '13 at 15:30
    
Is it possible for the Harddrive to mess up the controller just by being connected? I'm worried that if I try it on another computer, it will have to be on my brothers and I don't think he'd be happy if his controller messed up because I tested it on his. Would removing the CMOS battery perhaps help? Also another thing to note - since I tried to connect my 1.5TB after I did a clean install on my SSD, I haven't been able to use any USB keyboard after the bios screen. So I can use the keyboard to enter BIOS and but I can't use it to press ctrl-alt-delete to restart the system after I leave BIOS –  3lliot Apr 21 '13 at 15:35
    
Not permanently, no. Any messing up is lost upon removal of the power cord :D –  fuero Apr 21 '13 at 15:36
    
But it doesn't really make sense how the SSD can be perfectly bootable until I add the 1.5TB harddrive does it? If the 1.5TB harddrive is causing the SSD to be unbootable, couldn't it do the same thing to my brothers computer? Although I don't think it's reasonable to single down the cause of the problem on to the harddrive just yet but I've removed the power cord after connecting the 1.5TB Harddrive and I still get the disk read error on my SSD, even when then 1.5TB isn't connected. –  3lliot Apr 21 '13 at 15:43
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.