Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run the Resource Monitor program on windows 7 the window opens but the window is either blank or transparent with the desktop showing through the window frame. (even though no transparency is used normally in the displaying).

When the Display Properties DPI setting is set to 100% It works Fine, everything is as it should be. I am using "classic" desktop. The big problem is even with 24inch high-res monitors, I use 2 monitors, and having the text that small will not work at all. It is not just about the text size in Resource monitor itself or any single program, but arrays of programs that use the DPI setting that are too small.

What Can I change to have 125% DPI setting, classic display, and still view the resource monitor?
Do you know where to start looking to tweak something to change it?

The longer story:
At first I thought it was an aggressive firewalling that stopped internal communications to the resource monitor, or that it was services. I almost asked about that (and it would be wrong).

My second thought was that it was layers of recentally installed windows updates that changed things, because there were many (about 100) I would not know which one had changed anything. Here, they suggested it was an issue with

C:\Windows\System32\LogFiles\WMI there is a folder called "RtBackup"

I deleted that quick enough and it changed nothing.
Any information you have about how deleting WMI logging files (as stated in MSanswers) would have been a solution? (font size settings?).

At the bottom of that link is the suggestion that changing the DPI solutions it. Changing the DPI in Display to 100% does bring back the Resouce monitor. Everything is way too small with it on 100%, and my preferance is 125% setting in the DPI there. (which was working before).

The update item is claimed to be kb977074 Yet I do not see any update by that number in the installed updates on this computer. I assume some of the same "fixes" are installed via some other update.

Using an Areo display theme does not have the same problem. Using areo is not an option either usually because there is no fully perfect way to have a dark theme, and it uses resources unnessisarily to do a view that I do not even like. Basic is not classic, and it still uses aero, just not the transparency, that also does not solve the problem.

It is not an option to switch DPI mid stream just to view the resource monitor, because there are many things going on as a constant. logging off or rebooting, is not an option, this computer does not get booted for months, there is often working programs that are disrupted by rebooting.
Switching to aero theme (even basic) is possible without a log-off, so it is possible to use that (poor) method to view the resource monitor without a log-off or reboot.

share|improve this question
Got the same problem. Changed the theme to Windows 7 basic (theme without aero). Resource Monitor works again. – user224422 May 15 '13 at 5:49

3 Answers 3

I fixed this problem uninstalling Internet Explorer 10 and KB2670838 update and keeping the 125%

looks like the problem is the KB2670838 update that is automatically installed when upgrading to IE10

just uninstall both and it should work again

I found the solution here and here

share|improve this answer

Go to advanced system settings(Windows+pause, then click advanced system settings)

then go to advanced tab, then performance settings.

Enable use visual styles on windows and buttons(should be very last box).

share|improve this answer
I have empty window of resource monitor and have this checkbox checked, so this doesn't help me. – stiv Oct 9 at 12:38

"Go to advanced system settings then go to advanced tab, then performance settings. Enable use visual styles on windows and buttons(should be very last box)."

Once Resource Monitor has started OK using this method, you can revert and it continues working OK.

share|improve this answer

protected by slhck Apr 6 at 17:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.