Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Setup

I have a FreeBSD server with the following output of uname -a:

FreeBSD glacier 9.1-RELEASE FreeBSD 9.1-RELEASE #0 r243825: Tue Dec  4 09:23:10 UTC 2012     
root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64

It is using SixXS to establish an ipv6 tunnel with the virtual interface gif0 and acting as a ipv6 router for the LAN by router solicitation. I got a /64 subnet which is announced by the router and which the clients are using. The server is connected to the home LAN via a WLAN AP acting in bridge mode connected to interface em2. To speed up data transfer speeds the server is additionally connected to a gigabit LAN with the aggregated interface lagg0.

The WLAN is using the ipv4 subnet 192.168.9.0/24 and the gigabit LAN 192.168.0.0/24. Some desktop clients like my iMac is connected via both media to the server (wired and wireless network).

Overview of my network setup

My Problem

The LAN clients get their correct ipv6 addresses and are having ipv6 internet connectivity. The strange thing however is that I am not able to connect to my server in the same LAN via SSH over ipv6.

Could it be that it is problematic that the server is hosting two different ipv6 addresses (one on lagg0 and one on em2, so that it is reachable via gigabit ethernet and wlan)? Interestingly the ipv6 address of the WLAN interface on em2 is answering to pings, the lagg0 gigabit-connected ipv6 address is not answering.

My Questions

Is there a fundamental error in my setup? It seems to me that the routing is screwed up a bit, but I am not sure how to fix this.

Here is the configuration of my aggregated gigabit interface lagg0 (ipv6 address faked).

root@glacier  ➜ ~  ifconfig lagg0
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=4219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC,VLAN_HWTSO>
    ether aa:bb:cc:dd:ee
    inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255
    inet6 fe80::3285:a9ff:fea6:50bf%lagg0 prefixlen 64 scopeid 0x9 
    inet6 2a01:1e8:e100:821e::1 prefixlen 64 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    laggproto lacp lagghash l2,l3,l4
    laggport: em1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
    laggport: em0 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
share|improve this question
add comment

migrated from serverfault.com Apr 22 '13 at 7:17

This question came from our site for professional system and network administrators.

1 Answer

up vote 0 down vote accepted

The problem was that two network interfaces of the FreeBSD computer were connected to the same subnet. This means that it is impossible to route it properly.

The solution would be to give each interface lagg0 and em2 a separate IPv6 subnet and it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.