Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried running:

yum install boost boost-devel boost-doc


(1/3): boost-1.33.1-15.el5.i386.rpm
(2/3): boost-doc-1.33.1-15.el5.i386.rpm
(3/3): boost-devel-1.33.1-15.el5.i386.rpm 

Then it successfully installed the boost lib, but when I compile my script:

#include <boost/shared_ptr.hpp>
#include <boost/enable_shared_from_this.hpp>
#include <boost/bind.hpp>
#include <boost/asio.hpp>
#include <boost/thread/mutex.hpp>

But when it gets to:

#include <boost/asio.hpp>

Errors out:

Boost/asio.hpp: No such file or directory.

Question:
How do you install ASIO on CentOS?


UPDATE

I tried:

yum install asio-devel

Returned:

No package asio-devel available.

UPDATE2

Checked:

/usr/include/boost

And confirmed that asio wasn't there.
I'm trying to download the asio files and just upload it to the directory right now.
Hopefully it works.

share|improve this question

migrated from stackoverflow.com Apr 22 '13 at 8:49

This question came from our site for professional and enthusiast programmers.

    
what files does the boost-devel rpm provide? it should include Asio, are you sure they aren't in /usr/include? –  Sam Miller Apr 21 '13 at 18:23
    
Asio was in Boost since version 1.35 (IIRC). Perhaps, you've got a earlier version? –  Igor R. Apr 21 '13 at 18:28
    
Is it possible to uninstall then try to reinstall it back to check? –  zikdaljin Apr 21 '13 at 19:18
    
I tried reinstalling and just checked and ASIO is really missing from /usr/include/boost –  zikdaljin Apr 21 '13 at 19:23
    
@IgorR. It appears that he is using CentOS 5, which includes Boost 1.33.1 which, as you suggest, would not include asio. He could use the boost 1.41.0 version which is available from epel as the package boost141-devel. –  sharth Apr 21 '13 at 19:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.