Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you associate a filetype with a certain application in Snow Leopard? Apparently this is different than the last 20 years of Mac operating systems because every article I find about Leopard or before works a certain way (select file, Get Info, specify application under Open With, click Change All, confirm) but when you do this in Snow Leopard, when you Change All, it immediately reverts the app you chose back to what it was. No problem, so I reselect the app. Except now I'm only doing it for the specific file again. How do you associate a filetype with a specific app?

[Edit] apparently I can switch to some apps (e.g.: Firefox worked) but I can't switch to an app created by me from an applescript.

share|improve this question
1  
Yeah, Apple did in fact change it for Snow Leopard, there was some minor news about this difference, as it does differ from the past 20 years or whatever of mac history. Sorry I can't be of more help, since I don't actually own any macs, but just confirming that you aren't going crazy. –  davr Oct 21 '09 at 22:16
    
You are talking about UTL's.... Which do not prevent you from associating files with a particular application... They are a way for the programmer to indicate which files the application can use.... And to setup recommended defaults... But the user can still override. –  Benjamin Schollnick Oct 21 '09 at 23:52
    
@Benjamin, "UTI" rather than "UTL", I guess? If not, what's UTL? (For UTI, see appleinsider.com/articles/09/09/22/…) –  Arjan Oct 24 '09 at 12:06
1  
I don't know if it helps you, but you might want to read "How to associate the “.exe” extension to be opened with Mono?" at superuser.com/questions/67126/…, which uses Automator and in my Snow Leopard works for new files as well. It also worked fine with "Run AppleScript" (with, for testing, display dialog "" & input) rather than "Run Shell Script". –  Arjan Nov 7 '09 at 16:05
add comment

4 Answers

Try RCDefaultApp. You can browse and edit all the associations by UTI, extension, or app.

share|improve this answer
    
Too weird. This works on seemingly everything EXCEPT what I need it to: .url files. Great app though –  Dinah Oct 21 '09 at 23:08
    
Since you are having problems setting it to your own application, you might check into the CFBundleDocumentTypes key in its Info.plist file (developer.apple.com/mac/library/documentation/General/Reference/…). Maybe something in there is convincing Launch Services not to use your app for ".url" files. BTW you should always save AppleScript applications as "application bundle" (or just "application" in Snowy) for maximum compatibility (and easy access to its Info.plist). –  Chris Johnsen Oct 22 '09 at 4:55
add comment

It sounds like a bug. Call Apple if you have phone support or visit a Genius bar to see if it's not a known issue, or file a Radar. I'll test when I get home and file as well.

Edit: Tested, works fine for me, so not bug-worthy just yet. I'd advise rebuilding the Launch Services database as Benjamin Schollnick suggested.

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

Do you only have a problem switching to a specific application, or does changing the default handler from Safari to any other application (ex. WebKit, Opera) not work?

share|improve this answer
    
I ran what you posted in terminal then tried again but no go. I can switch to other stuff but not to the app I created. Ex: I've done so with Firefox. –  Dinah Oct 22 '09 at 1:51
add comment

Snow Leopard is the same as the other OSes... File Info is the correct way to go... But the Launch Services Database appears to be damaged / corrupted.

First try a safe boot, by rebooting with the left shift key depressed, reboot again after the login window appears, and try reseting the default application.

If that doesn't work, then download Cocktail (Snow Leopard edition), and then use the System --> Databases --> Rebuild

share|improve this answer
    
Sadly, neither worked. I still cannot the file extension .url with my new app. Thanks anyway. –  Dinah Oct 21 '09 at 23:15
add comment
up vote 0 down vote accepted

Even after rebuilding the db and after calling AppleCare, no solution was found to this problem. Files could only be associated one at a time with the app created by me. But I could open a .url file in OS X FireFox which prompts FF to ask which app to use. From here I could select my app and 'always open with'.

share|improve this answer
    
So, this question was only about files with a ".url" extension? Did you come up with that extension yourself, or if not: what kind of files are that? (I only have ".webloc" files when dragging URLs from Safari or Firefox.) –  Arjan Oct 24 '09 at 12:00
    
And now opening ".url" files first opens Firefox, which then starts your own script of choice? –  Arjan Oct 24 '09 at 12:01
1  
@Arjan van Bentem: RE 1st comment: .url files are the Windows version of .webloc and OS X FireFox will not open them. RE 2nd comment: yes, after doing what I said in my post, FF now opens them using my app (created from an applescript) which in turn parses the file and opens the contained url in FF. It's crazy ugly but I've been looking for solutions for over a week and can't find anything better. –  Dinah Oct 24 '09 at 18:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.