Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am entering the following command on Windows Server 2003

net use X: \\Samba_Server\gis  /user:Administrator <admin-pwd>  /persistent:yes

And I get the following error:

System error 1326 has occurred.
Logon failure: unknown user name or bad password.

What am I doing wrong?

Without the /user:Administrator <admin-pwd>, it mounts fine. I want the credentials to be persistent across logins.

share|improve this question
    
Does it make a difference if you use /user:Samba_Server\Administrator? –  Oliver Salzburg Apr 22 '13 at 14:46
    
Please make it an answer. The Password is the Samba server's user, which is not how it seems mounting the drive using Microsoft Explorer works, because I tried a local user name. –  octopusgrabbus Apr 22 '13 at 14:53
    
What if you put the <admin-pwd> in quotes like "<admin-pwd>"? Sometimes it helps if there are special characters in the PW. What if you leave the password away altogether? Are you prompted to enter the PW? –  Simon Apr 22 '13 at 14:54
add comment

2 Answers

up vote 5 down vote accepted

You might have to specify explicitly that you want to reference the user account on the remote system, otherwise, Windows might try to establish the connection referencing your local Administrator account.

To do this, supply the domain (in this case the name of the remote computer) with the /user: parameter:

net use X: \\Samba_Server\gis /user:Samba_Server\Administrator <admin-pwd> /persistent:yes
share|improve this answer
add comment

The syntax command that you have entered is correct. Error 1326 is a common error number used to denote authentication failures on Windows system. These failures are usually related, but not limited to:

  1. account does not exist
  2. guest account needs to be enabled
  3. auto-logon and blank password is enabled on remote computer
  4. folder or drive permissions shared on the remote computer

In your case, if you have checked that the account you are using exists on the remote computer(1), the problem might be caused by point 3. SAMBA shares has a configuration option when turned on would exhibit this behavior on Windows clients.

guest only = yes

More information on this option can be found http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html#GUESTONLY

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.