Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to reinstall an OS on my truecrypt device. The whole drive was encrypted and now I want to delete EVERYTHING without decrypting the stuff.

I have tried different approaches like GParted and similar, but without any success:

  • GParted: I deleted both partitions and created a new one (ntfs formatted)
  • Used the rescue tools of Windows 7 setup (fixmbr), but same problem.

The setup says it needs a driver (Using browse shows up my formatted device). Googling shows up that it should be a problem with TrueCrypt.
I never had problems before. They appeared after using TC to encrypt the system drive.

Is there no way to wipe the whole drive to allow a reinstall?

Thanks for any hints.

share|improve this question
    
"I have tried different approaches like GParted and similar, but without any success." Edit your question and tell us what went wrong, and what you expected to happen, when you attempted to use GParted or similar and we may be able to help you. –  Scott Chamberlain Apr 22 '13 at 15:33
    
If the entire drive was encrypted just getting rid of the parition would wipe the contents. –  Ramhound Apr 22 '13 at 15:37
    
Okay, added some more information. :) –  CSchulz Apr 22 '13 at 15:40
1  
@CSchulz - Just delete all partitions. Use the Windows installer to create a new partition. –  Ramhound Apr 22 '13 at 16:07
    
Doesn't work. The setup has never accepted the drive as possible target. There is no difference between the manual erase of partition or not. You can see the drive as browsable device to find drivers but not more. Do I have to delete something else? Mark the device other or similar? –  CSchulz Apr 22 '13 at 16:16

3 Answers 3

boot your GParted CD and see if you can find a terminal window. Then make note of the drive you want to wipe is it sda sdb sdc sdd or what.

Then try: (Replace sda with whatever drive you want to wipe.)

dd if=/dev/zero of=/dev/sda bs=512 count=20000

reboot and see if you can install windows now.

share|improve this answer

On windows, if you can get windows to recognise it as a disk, do

diskpart
list disks
select <your disk>
clean disk <your disk number>

After which you should be good to go.

share|improve this answer
up vote 1 down vote accepted

My problem was caused by something else. To delete the encrypted system disc, you can use the suggested solutions with gparted, diskpart or dd.

The solution for my problem was switching the USB port. But it is not the full truth, it seems to be a problem with USB 3.0, mentioned here. So it was a problem with the windows installer, not TrueCrypt itself.

share|improve this answer
    
In its initial version, it wasn't apparent you were actually answering your own question ("use one of the suggested solutions"). But now that's more evident, so thanks for editing it. –  slhck Apr 23 '13 at 8:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.