Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When transferring files larger than ~17GB to/from a Windows Storage Server 2008, user gets error along the lines of "Could not complete transfer, do you want to try again?" Trying again always fails.

  • I have tried using a different ethernet adapter, that did not help. (onboard Broadcom to PCI(e?)Intel)
  • I updated the ethernet driver, that did not help
  • Ran a SFC, that did not help.
  • I tried having using xcopy, Robocopy and Richcopy, all of them fail (all with unbuffered IO enabled).

What could be the reason the files are failing? What else can I try?


Update 1

  • trying manually setting port and NIC to 1gbps/FD - didnt help

Update 2

  • I monitored the transfer, definitely on files that large, the machines memory usage skyrockets and ends up paging and cant keep up with the transfer. This is why unbuffered IO is necessary.
share|improve this question
    
Does this only affect a specific workstation/user? Is the local filesystem full maybe? :P –  Oliver Salzburg Apr 22 '13 at 17:18
    
9TB free on the destination server –  Keltari Apr 22 '13 at 17:31
    
it fails for one user trying to move files from 2 other servers... I havent tried it myself though –  Keltari Apr 22 '13 at 17:32

2 Answers 2

up vote 1 down vote accepted

UPDATE:

It turns out the Windows Search service was the culprit. Looking at the resource monitor, specifically at the disk, I saw the average disk time was maxed on the graph and searchindexer.exe was reading/writing nonstop. When I stopped the service, disk usage dropped off and the 37 GB file was able to be dragged & dropped.


Well, I did some research and tried a different utility.

I copied the Extensible Storage Engine Utilities for Microsoft(R) Exchange Server (eseutil.exe) and its associated files to the destination machine's windows directory.

Then ran the following:

eseutil /y \\freyasqlcluster\Backup_Freya\Monthly\WSS_Content_YSERANew_backup_2013_01_31_000004_1043305.bak /d \\vash\d$\temp\test.bak

This successfully copied a 37GB file in 71 minutes. This method worked better than all the other utilities I have tried. Unfortunately, the user who will be using would still prefer a GUI, which would make it easier... but no luck finding one that works as quickly, or as well.

I dont understand why the specialized copy utilities (from MS!) do not work as well as this CLI utility that wasnt even intended for this use.

I will use this method, but hopefully someone can recommend a GUI that works as well as eseutil.

share|improve this answer

I'd suggest you can try creating a .torrent file by adding it and subsequently adding the torrent file on your PC and transfer it

share|improve this answer
1  
Could you detail a little more on how to do this? It would improve the quality of this answer ;) –  KronoS Apr 22 '13 at 18:21
    
I didn't see whether the server was in a local network or on internet. Once that is clear I'll add instructions how to do this. –  Karan Raj Baruah Apr 23 '13 at 1:10
    
You could do both ;) –  KronoS Apr 23 '13 at 1:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.