Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all, sorry for my English

What are the transfer rates of files between a network and a wireless AP?

I have a home server connected to a wireless router via ethernet and i'm not able to get more than 5-6 MB/S

  • 2.4 ghz - 20MHz ----> 3-4 MB/s
  • 2.4 ghz - 40MHz ----> 5-7.5 MB/s

Clients are notebook not compatibile with 5ghz.I tried with

  • RT5390R (Ralink RT5390R 802.11bgn Wi-Fi Adapter)
  • RTL8188CE (Realtek RTL8188CE 802.11b/g/n)
  • INTEL 5100 (This one i think is n-draft)

Router:

  • thomson TWG870
  • Linksys wrt160Nv3 with and without dd-wrt

IPERF:

client(wifi)--->client(wifi)

[156]  0.0-60.0 sec   117 MBytes  1.94 MBytes/sec

client(wifi)--->client(ethernet)

[156]  0.0-60.0 sec   231 MBytes  3.86 MBytes/sec

In addition, i can download from internet(via ethernet of course) at 10 MB/s but with theese speed i get from my router i can not take advantage of

share|improve this question
1  
What are the specifications of the laptop's WiFi card? If it's 802.11g, that's actually better than I would have expected. –  David Schwartz Apr 22 '13 at 22:49
    
@Znau: He's measuring true data transfer rates, which are usually measured in MB/s. –  David Schwartz Apr 22 '13 at 23:11
    
What OS are you running? FYI: Speed declines with an increase in distance. –  cybernard Apr 23 '13 at 1:14
    
Try to switch wireless channels use channels 1, 6 or 11. Try to configure router to n-mode only. –  Nikolai Apr 25 '13 at 7:34
add comment

1 Answer

if you're sure you're running in 'n' mode from client to ap, then you might check the router settings to make sure things like in dd-wrt > wireless > advanced that you don't have the transmission fixed rate set low.

also check for tx errors on the status page, if you have a lot of them you might try adjusting your ack timing (try 0, if it doesn't help try about how many meters you are from the ap and add 30) if you're still dropping packets you might potentially lower your beacon interval to 50ms and adjust fragmentation and rts tresholds a little as well (follow the instructions here: http://www.dd-wrt.com/wiki/index.php/Advanced_wireless_settings#Fragmentation_Threshold )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.