Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm about ready to give up on Firefox, because whenever I shut it down, it's still working in the background, and if I leave it up it, then over time it works more and more. My hard drive is really being worked, and my system is slowing down.

I have the latest version (3.5.3).

Any ideas on why it is not vacating memory when it's done, and clogging things up?

share|improve this question
What's your OS? When I was running XP I found this to be the case, so when I'd exit Firefox, I would get in the habit of force quitting it. – emgee Oct 22 '09 at 0:39
I'm using XP SP3. – Lance Roberts Oct 22 '09 at 15:08
up vote 3 down vote accepted

Mozilla has a very detailed article on troubleshooting hangs in Firefox, for your such issue:

Hang at exit

Sometimes when you close Firefox, it may stop responding and remain in memory, even though no Firefox windows are open. This can prevent Firefox from working properly the next time you open it or you may see a "Close Firefox" dialog box with the message, Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.. You must then end all Firefox processes or restart the computer before you can reopen Firefox. (See Firefox is already running but is not responding for other causes and solutions.)

If Firefox processes that remain in memory at exit are a recurring problem, try these solutions:

  • A problematic extension can cause the problem, which can be resolved by disabling or uninstalling the extension. For information on diagnosing and fixing problems caused by faulty extensions, see the Troubleshooting extensions and themes article.

  • Sometimes Java applets can cause the Firefox process to persist after exit. Try updating Java to the latest version or, if you don't need Java, disable the Java plugin by clearing the "Enable Java" checkbox in Firefox (see Using the Java plugin with Firefox for details).


  • Using certain Internet security software is reported to cause the issue on some systems:

    • If you use ZoneAlarm on Windows Vista, uninstall it and use another firewall product (or use the Windows Firewall).
    • If you use Avast! Antivirus, switch to another antivirus product if you also have ZoneAlarm installed.
    • If you use Norton 360 2.0, make sure that you have all available Norton updates (for more help, contact Norton Support) and that you have followed the instructions in the Configuring Norton 360 article.

    • If you have upgraded Comodo Internet Security from a version prior to 3.10, the Comodo Safe Surf component from the previous version can cause Firefox to hang at exit. To resolve the issue, you can uninstall Comodo Safe Surf via Windows Control Panel, as its function is now integrated into the current Comodo application.

share|improve this answer
Thanks for the info. I'm amazed they haven't fixed this since it's a known problem. I guess I'll just have to give up on Firefox (which I only use for the ReloadEvery functionality). – Lance Roberts Oct 22 '09 at 15:14

What extensions do you have installed? Many times this is actually because of poorly written extensions rather than FF itself.

Try using Firefox Safe Mode and see if the behavior continues. Safe mode for FF starts with no extensions/add-ons enabled.

share|improve this answer
I'll give that a shot just to see, though it defeats the purpose of using Firefox, since the only reason I use it is ReloadEvery. – Lance Roberts Oct 22 '09 at 15:12
If it works fine, you can start disabling extensions one at a time until you find the culprit. That's just step 1 – MDMarra Oct 22 '09 at 15:42

Try opening up Windows Task Manager, click on the Processes tab, then watch the Firefox.exe process as you close it.

It may just be that you have several memory hungry extensions and lots of tabs open at the same time. In this situation, the Firefox process can hang around for several minutes after the user thinks they have closed it while it cleans up after itself. You should be able to watch the process memory usage slowly decrease in Task Manager.

Hope that helps somewhat.

share|improve this answer
Actually, it never leaves memory until I kick it out. – Lance Roberts Oct 22 '09 at 15:10

This drove me crazy. The apparent solution is to delete the "parent lock" file in your Firefox profile folder. Make sure Firefox is off, go to start menu search box and type or paste %APPDATA%\Mozilla\Firefox\Profiles. Click on the file that appears in search results. This opens your profile folder. Scroll down to parent lock and delete it. You can only do this when Firefox is closed.

The other thing that helped was disabling add ons, particularly Ad Blocker and Auto Fill. This is a pain, though, disabling and enabling add ons all the time.

Firefox seems to be great when you first start using it, but over time, it really gets messed up. I seem to have fixed the problem for now, but if it starts up again, I'm defecting to Google Chrome. Too bad, because I'm used to Firefox, and Chrome isn't so user friendly, IMO.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .