Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

System:

  • CPU Core i7 3770K
  • Motherboard Asus P8Z77-V with latest BIOS
  • RAM 32GB DDR3-1333
  • RAID Adaptec 6405E in a PCI-E 3.0 x4 slot
  • HDDs 2 x Seagate 4TB 7200RPM
  • GPUs Intel HD4000 (on-CPU) and Radeon HD7970

Software:

  • OS Windows 8 Pro x64
  • Intel GPU driver 9.18.10.3071, latest as of this writing
  • AMD driver Catalyst 13.1, latest stable as of this writing
  • All Windows updates, latest motherboard drivers, latest RAID controller firmware (19109), etc.
  • Want to use LucidLogix Virtu MVP 2.0, but won't be able to install it until I can get past this issue

Configuration:

  • One HDMI and one DVI monitor plugged into the motherboard
  • No displays plugged into the AMD Radeon HD7970

Problem:

code 12 hd4000

Picture says it all. Stuck on 1280x1024 resolution, single monitor, no 3d rendering.

What I've tried:

  • I've tried uninstalling every single device under "System devices" in Device Manager.
  • I've tried uninstalling Catalyst, using a different version (13.3 Beta 3), disabling the Radeon and rebooting, and physically removing the Radeon from the system.
  • I've tried completely uninstalling the Intel driver, deleting all registry settings related to it, deleting its directory that it leaves behind, and trying the four previous versions of the driver.
  • I've tried using the version of the Intel driver distributed on the ASUS website under the drivers for my P8Z77-V motherboard.
  • I've tried installing LucidLogix Virtu MVP software, but this just gives me a black screen when I log in, and I have to boot into safe mode and uninstall it to get a desktop back.
  • I've tried disabling my internal SATA controller, internal network controller, USB host controllers, sound cards, COM port, and everything else not strictly required to operate the OS. One time I inadvertently uninstalled the USB host controller powering my keyboard and mouse, so I had to reboot.
  • I've tried running msinfo32 and looking under conflicts, but the HD4000 controller does not show up as having a conflict.
  • I've tried toggling the "iGPU Multi-Monitor" setting in the BIOS.
  • I've tried toggling the "Memory Remap Feature" in the BIOS.
  • I've tried changing the "iGPU Memory" amount in the BIOS from "Auto" to 32M, 64M, 128M, 256M, 512M, 1024M.
  • I've tried toggling the "Render Standby" setting in the BIOS.
  • I've tried disabling the on-board VIA 1394 controller in the BIOS.
  • I've tried disabling on the on-board WiFi controller in the BIOS.
  • I've tried booting from UEFI, and booting from BIOS. Unfortunately I can't use UEFI GOP mode because my Adaptec 6405E only has a BIOS Option ROM, so the Compatibility Support Module has to be enabled to boot successfully.
  • I've tried toggling Fast Boot, Option ROM, Spread Spectrum, XMP / Auto / Manual mode, and almost every other setting in the BIOS.

For the life of me, I cannot get my HD4000 to work under any circumstances. The only way I can get working 3D graphics is by plugging my monitors into the Radeon HD7970, and setting the primary display output to the Radeon. Once I do this, all hope of ever using the HD4000 for anything is completely lost, as it stops being detected in the device manager, like it's not even there.

How can I use my HD4000??? This is a nightmare!

share|improve this question
    
Toggling the settings one by one doesn't ensure you've ever tried with all settings correct. –  David Schwartz Apr 23 '13 at 4:19
    
If you have a dedecated GPU way are you using the Intel HD4000 for your display adapater? The HD4000 is not exactly a performance beast. –  Ramhound Apr 23 '13 at 11:17
1  
For several reasons: (1) OpenCL on the HD4000 can be used simultaneously with or independently from the Radeon; (2) Intel QSV for video encoding on the HD4000 is faster than anything out there for the Radeon, and I have software that supports QSV; (3) The Radeon can basically go to sleep when the system isn't doing heavy 3D, and the HD4000 is much more energy-efficient than the Radeon at small/desktop/2D workloads; (4) almost fully half of the area of my CPU die is consumed by a chip that I currently can't use, and I'd like to. Aside from this I don't feel I have to justify why I want to ... –  allquixotic Apr 23 '13 at 13:48
1  
... do something; that I want to do it, and that it's not supposed to be this hard (in fact it's explicitly supported by the LucidLogix Virtu MVP hardware to use both GPUs in tandem), should be enough. So please do not argue with me about why I want to do it, unless you happen to know that this is something which is unsupported. As far as I know, the vendors consider this a fully supported setup, but it just doesn't work. –  allquixotic Apr 23 '13 at 13:50
    
I should add that when I was running Windows 7 x64 using drivers from around May 2012 with this exact same hardware, the Lucidlogix Virtu MVP was working reasonably well. There were bugs in the early drivers, but the core feature of having both the iGPU and the discrete GPU operable at once was implemented and nominally working. Somewhere between the Windows 8 upgrade, the software I've installed and the driver versions I'm using, the HD4000 has broken, even if I use it alone without the Radeon attached to the system. –  allquixotic Apr 23 '13 at 13:52

2 Answers 2

up vote 1 down vote accepted

I've also recently become a victim of this, except my discrete card is Nvidia. Fundamentally it is a Windows issue since Linux works just fine with 3 monitors (2 on Intel, third on Nvidia). A lot of people have posted about having this issue and being unable to resolve it. A few have managed to recover.

The only solution I've seen people always have success with is a complete clean operating system install.

share|improve this answer

I have faced to the same issue for about a month ago.

The only way to resolve it it's to downgrade the bios, the latest that work for me is the 1616.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.