Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had an old laptop that died so I have bought a new one. I have taken the 2.5 SATA hard drive from the old laptop and I have put it into an external 2.5 SATA enclosure usb 3.0 and I connect it to the new laptop. My new laptop has Windows 8 64 bit installed. When I connect the external hard drive to the new laptop throught USB 3.0 port, it gets randomly disconnecting and reconnecting continuously, even when I am not using it. Also happens if I connect to another usb 3.0 port. Also I have observed that If I connect the external hard drive to a USB 2.0 port instead of an USB 3.0 port all work ok, no randomly disconnection and reconnection occurs. It only happens when I connect it to an USB 3.0 port.

Some ideas to solve this issue?

share|improve this question
    
I was having this same issue (HP Probook 4540s, Windows 8.1 64bit) and tried several solutions given by different forums. Finally got this and solved my problem. plugable.com/2012/12/01/… –  Safeer Hussain Feb 26 at 16:09
add comment

2 Answers

This is typically due to a power configuration option. Go into device manager and don't allow the computer to put the device to sleep!

enter image description here

If this doesn't work, try playing with the power options in Control Panel

share|improve this answer
    
Ok, I'll try it later when I come back home and I'll tell you something here(now I am at work and I can't), but I wonder why it happens with USB 3.0 only and not for USB 2.0 (USB 2.0 works). –  user1624552 Apr 23 '13 at 8:12
1  
@user1624552 - USB 3.0 is able to draw a great deal more power. Its likely a power saving option that the OEM decided was worth enabling by default. –  Ramhound Apr 23 '13 at 11:04
    
@user1624552 did it work or not? –  Dave Rook Mar 6 at 8:43
add comment

This worked for me in addition to the setting above.
Go to:

  • control panel
  • power options
  • change plan settings
  • change advanced power settings
  • USB settings
  • USB selective suspend setting
    The set the plugged in option to disabled.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.