Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have run this same backup command on previous versions of MediaWiki (on Centos 6.4) and it has worked successfully but now when running this command on MediaWiki 1.20.4 -

[root@wiki images]# php /var/www/html/wiki/maintenance/dumpUploads.php --base=$(pwd) | xargs -I foo cp 'foo' . -v

I get the following errors -

cp: cannot stat `mwstore://local-backend/local-public/0/07/Xvidcap-test.swf': 
No such file or directory

I can see this is because the location does not exist but how can I get around this?

share|improve this question
Would there be the possibility to download the images manually? What is the mwstore? If I run a locate for the image it is not found but it is in the wiki. The defulat location for images is /var/www/html/wiki/images and there is a similar file structure [root@wiki images]# ls 0 1 2 3 4 5 6 7 8 9 a archive b c d e f lockdir README thumb – Josh Apr 26 '13 at 12:44
Ok so my work around is this - find /var/www/html/wiki/images/ -type f -exec cp '{}' ./ \; – Josh Apr 29 '13 at 8:27
ugh, that can go wrong in quite many ways. Why don't you just tar cf images.tar /var/www/html/wiki/images/? – Nemo May 3 '15 at 12:34

Manual:dumpUploads.php recommends tar, like php maintenance/dumpUploads.php | xargs tar cf backup_files.tar.

However, if your aim is backup, you should preserve the directory structure you're using. As Manual:Backing up a wiki recommends, just use tar, e.g.:

tar caf images.tar.gz /var/www/html/wiki/images/

if you want to backup the uploads only and to compress them a bit.

Note, mwstore is the file backend.

share|improve this answer
That hasn’t worked for at least a couple versions, not even at the time you posted it. You cannot directly tar output like mwstore://local-backend/local-public/example_2.png. – TechZilla Dec 9 '15 at 18:23
@TechZilla I'd call that a bug, but the first line is only an introduction to the matter. My proposed solution is the second command, did you try that? – Nemo Dec 10 '15 at 8:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.