Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently decided to build myself a new, cheap(ish) rig mainly for HTPC use and I have now run into a BIG problem.

The system simply refuses to show any signs of life.

Problem:

When I press the power-button on the case the power-switch LED light turns on briefly and the PSU fan manages nudge maybe half an inch and then nothing happens. No POST, no UEFI, no nothing. This problem has existed from the very beginning so the setup hasn't yet been in a working state.

Actions so far:

At first I suspected the PSU was the culprit but I tested the setup with the PSU from my gaming rig with the exact same results so that wasn't it.

My suspicions then turned to the motherboard so I then breadboarded my way through every combination of components imaginable with whom the system should at least start up and POST. Once again, no luck. I also tried a CMOS reset with no luck. After this I decided to RMA the mobo. I finally got a new mobo and this is where things get interesting.

I breadboarded my way upwards from only the CPU, one stick of RAM connected and front panel USB2 and audio connectors connected and this, as expected, worked. UEFI started up without a hitch and everything seemed to be working fine. Both sticks of RAM connected worked as well. I then proceeded to connect the HDD to the SATA connector and the USB3 front panel connector. At first I forgot to connect the power cable to the HDD but the system still started into UEFI with no problems. At this point it's also worth noting that both PSUs worked equally well at this point. I then proceeded to connect the HDD power cable, the SATA and power cable for the DVD-drive and front panel fan.

After that, everything died on me again. The PSU fan occasionally tries to spin and the power switch LED reacts when pushed in the front panel but once again, no POST, no UEFI, no nothing. Once again, the results are the same with both PSUs.

I have once again tested the build both inside and outside the case with all combinations of components imaginable with no luck at all. The CPU and socket pins are also ok together with the cooler and thermal paste. I have also tried to jump-start the motherboard from the motherboard connectors with no luck. The system stays dead. The mobo has no LEDs on it so troubleshooting this way is not an option in this case. I have, at least in my own opinion, also ruled out any visible risks for shorts inside the case. I tried during the weekend to isolate the mobo from the case standoffs with rubber o-rings but, again, no luck.

Is there anything more I can do at this point or should I just get myself a new mobo at this point?

The setup is as follows:

  • AsRock H77M-ITX
  • i3-3225 with Phanteks PH-TC90LS cooler
  • Kingston HyperX Genesis 2x4GB
  • WD Caviar Green 500GB
  • Corsair CX430W
  • Cooler Master Elite 120 Advanced
  • Phanteks PH-TC90LS
  • Some ASUS DVD/RW drive

Any suggestions and ideas would be very much appreciated at this point as I'm slowly starting to lose my sanity with this one!

E: Yes, I have checked and checked again the CPU power connector and it's the right one, believe me.

And I have also plugged and unplugged the drive(s) several times after the build decided to go dark on me the second time. As I mentioned, I have breadboarded my way through all combinations of components I could think of that should, in normal circumstances, at least boot into UEFI. This both inside and outside the case.

I have been through my fair share of computer building in my life but I have not come across anything like this before so i'm completely puzzled by this at this point

share|improve this question
3  
you have connected the power connector for the CPU right? –  Sathya Apr 23 '13 at 12:28
    
After all that you didn't bother unplugging the drive again? –  psusi Apr 23 '13 at 14:03
    
@white - Have you been in touch with tech support?with all that you have done, you may have to RMA again. Although if it were me, I would give up on AsRock and get your money back and go for a competitors brand. –  Carl B Apr 23 '13 at 18:52
1  
@white, take a look superuser.com/help/user-merge –  soandos Apr 24 '13 at 6:46
    
@soandos Didn't notice that, thanks! –  white Apr 24 '13 at 7:48
show 2 more comments

2 Answers

Your Motherboard is not being powered properly. Check your connection PSU <-> Motherboard. Check again, and again and again...

share|improve this answer
    
From what the OP has listed in troubleshooting, It looks as though it may be time to conclude that the board is dead and may have been produced in a bad batch. Sometimes, there is only so much you can do and the board is just no good. –  Carl B Apr 23 '13 at 19:54
    
Right. Had this so many times and spent hours trying to find a solution...when it was dead. –  M.Bennett May 2 '13 at 13:24
add comment

From what I read...

I then proceeded to connect the HDD to the SATA connector and the USB3 front panel connector. At first I forgot to connect the power cable to the HDD but the system still started into UEFI with no problems.

You connected the Hard Drive, data only, tested, and the system still worked. So, essentially no change from the previous setup that worked... as far as devices drawing from or connected to the PSU. Then...

I then proceeded to connect the HDD power cable, the SATA and power cable for the DVD-drive and front panel fan.

So, you went from the system working, to connecting three different components to the PSU. Any one of the three could have been the culprit, since the system ceased to function properly after that. The problem with your diagnostic process, is that you did not connect only one at a time to the PSU. Would it have made all that much of a difference at this point? It appears not, since you disconnected the drives and it did not function.

It appears that connecting one of those three components damaged the motherboard... which would point to the issue being the hard drive, the optical drive or the case fan. I know, it is unlikely it is the case fan, but still.

You could test those three components in another computer, but I'd hate to see you waste another motherboard.

share|improve this answer
    
I am very much aware of the fact that things went wrong when I connected all three components at once. The thing is, I wasn't at all aware that I actually wasn't troubleshooting the mobo but instead something else entirely at that point. I didn't even imagine that one of the three components could be the culprit. I think I learnt my lesson on this part... Is there any way to further troubleshoot the HDD or the DVD without risking any other components or computers? –  white Apr 24 '13 at 9:47
3  
Without paying someone else to troubleshoot the drive, I'm certain that a safer route lies in checking the hard drive via a USB interface... using a USB to SATA converter or an old External drive case. This should also work well for checking the optical drive. Putting a separate interface with a separate power source between the drive and the motherboard might risk the interface itself, but it would definitely be a workable buffer. –  Bon Gart Apr 24 '13 at 12:40
    
@white Maybe you could find the problem with a multimeter. Seems like the only way a drive would fry the board is if it shorted 12V to one of the data pins, or maybe to 5V or 3.3V. –  derobert Apr 24 '13 at 19:35
    
@BonGart I think I'll give a USB to SATA converter a go first. –  white Apr 25 '13 at 7:34
    
@BonGart Ok... I got myself a USB-SATA adapter during the weekend and tested both the DVD-drive and the HDD. Both worked mechanically as they should and the adapter itself stayed intact. Neither of the drives mounted but I guess this has something to do with the fact that the old Mac I tested the drives with is at its very last legs at this point. I guess I have to start poking around with the multimeter next... –  white Apr 29 '13 at 11:48
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.