Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've trying to solve a problem like the one described in Laptop starts up by itself after being in Hibernate but unfortunately the common suggestion of using powercfg to disable the LAN adapter from being able to wake the machine isn't working. I get the following description of devices that can wake the machine:

C:\Users\User>powercfg /devicequery wake_armed
NVIDIA nForce 10/100 Mbps Ethernet

but when I attempt to disable the device I get the following error:

C:\Windows\system32>powercfg /devicedisablewake "NVIDIA nForce 10/100 Mbps Ethernet"
Invalid Parameters -- try "/?" for help

Any ideas how I can disable this setting?

EDIT

It occurs to me that the problem may be the presence of a slash in the device name. Is there some way of quoting this that might alleviate the problem?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The trouble probably does have to do with the slash in the device name, but I'm unsure how you'd go about quoting it; the Windows command shell's quoting capabilities are both weak and bizarre. Instead of using powercfg, try disabling wake on the device via Device Manager:

  • Start -> Run -> devmgmt.msc, OK
  • Right-click the network adapter entry; choose 'Properties'
  • In the 'Power Management' tab, uncheck 'Allow this device to wake the computer'
  • If Wake-on-LAN capability is desired, check 'Only allow a magic packet to wake the computer'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.