Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently had to replace the caddy for my external HD. I was successfully using a 5m USB mini to USB A cable to transfer data between the HD and my laptop (Win 7 64).

The new caddy has a USB A socket, so I bought a 3m USB A to USB A cable. The caddy has its own power supply. When I plug the cable in to my laptop, nothing happens. Device Manager says there's an unknown device under USB controllers. The disk doesn't sound like it's initialising.

I tried the cable with a 2.5" external HD, too. The result is the same.

Both HD caddies work with a much shorter (30cm?) cable.

Thinking the cable was faulty, I ordered a replacement. Again, the same results, so I'm thinking it's a problem with that batch of cables OR my laptop OR the cable type.

I tried the cable with another laptop and the caddies. Same results, which seems to rule out my laptop.

Given that the Device Manager seems to recognise something when the caddy is attached via the cable, I'm uncertain of a faulty batch, so could there be a problem with the type of cable I'm using?

share|improve this question
    
Have you verified that there are no special drivers for the caddy's internal controller? Can you try it on a different OS or computer and see if there are any issues? Right now it sounds like you actually have connectivity (the USB bus can see the device is there, or at the very least it sees the voltage present). The cables are built in such a way that each connector really only fits into one type of port. If it fits on each side, you should be ok. –  Matthew Apr 23 '13 at 15:06
    
@Matthew Both HD caddies work with a much shorter (30cm?) cable. So the HD does work. –  Alvin Wong Apr 23 '13 at 15:08
    
Thanks, I missed that part! USB spec allows for up to a 5m cable when using USB2, but most likely that would assume an excellently made cable, probably with ferrite beads. Possibly cable quality combined with length? –  Matthew Apr 23 '13 at 15:21

1 Answer 1

While your cable length is still within USB 2.0 specs (length max. 5m), I suspect it's simply too long, see also some details the USB Developer's FAQ.

On long cables (where long means that the one-way traveling time on a transmission line is longer than approx. 1/6 of the (minimal) rise time of the driving circuit, Reference unfortunately in German) the correct termination at the end is crucial to reduce reflections.

Probably the termination was done carefully in your old caddy, but not in the new one to work with such a long cable, which is at the limit of the spec.

You can try to attach a hub to your HDD caddy with a short cable and use the long cable to connect the hub to your computer. There might be a chance that the hub will provide better signal quality. According to this answer a maximum of five (powered) hubs can be chained.

I haven't tried this myself, so I think the best solution would be to use a shorter cable if you do not need the full 5m at all circumstances.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.