Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mostly use Notepad++ for dealing with XML files. It would be good if Notepad++ parsed and colorized my files based on the XML language when I open the files. Instead, I have to open the file, pick XML from the Languages menu.

Is there a way to tell Notepad++ that XML is the default language and to treat the files accordingly.

share|improve this question
    
Does it not recognize the .xml file extension? Or are you using some crazy extension for your files? –  Sasha Chedygov Oct 22 '09 at 3:03
1  
@musicfreak: I believe AngryHacker is asking about the highlighting when they click File -> New file, which doesn't have an extension until you save it. –  Joshua Oct 22 '09 at 3:08
    
It's a .config extension and I have Notepad++ set up to be the default app for that extension. –  AngryHacker Oct 22 '09 at 3:35

4 Answers 4

up vote 47 down vote accepted

In Notepad++ open the Preferences dialog box by clicking on Settings -> Preferences click on the New Document/Default Directory tab and change the Default Language to XML.

Notepad++ Preferences

EDIT: Just saw that you wanted it to apply to .config files as well. This can be done but you'll need to do it for every extension you want to override. Click on Settings -> Style Configurator scroll down to XML in the language section and add config to the User ext box. Save & Close and any new .config file opened will show up as XML. In fact, I've already done that for my installation as seen below:

Style Configurator

share|improve this answer
    
This setting only applies to new files, not existing files your opening. –  heavyd Oct 22 '09 at 3:10
    
This does not work. The default language sticks between sessions, but the file is not syntax-colorized, until I manually select Language/XML. –  AngryHacker Oct 22 '09 at 3:15
4  
Perfect, your edit worked. Computing nirvana. –  AngryHacker Oct 22 '09 at 16:27
    
Works for NEW files, not opening existing ones. Too bad. Thanks for suggestion. +1 –  Felipe Alvarez Mar 31 '11 at 23:35
    
Thanks, I'd forgotten how to do this. Kept looking in Settings->Preferences instead of Settings->Style Configurator. -_- –  alimbada Feb 13 '12 at 12:59

In the Notepad++ directory look for the langs.xml file.

Find a node like the one below and add "config" as shown.

<Language name="xml" ext="xml xsml xsl xsd kml wsdl config" commentLine="" commentStart="&lt;!--" commentEnd="--&gt;" />

Restart Notepad++ Open a .config file. It should be formatted as XML.

share|improve this answer
    
You can do this through the GUI too, I believe. (It's been a while since I've used Notepad++ though.) –  Sasha Chedygov Oct 22 '09 at 7:17
    
I tried that to add some more PHP file-types, but didn't seem to work. :-( –  Simon Jul 21 '11 at 23:11
    
Just the job - thanks very much! –  sd_ Jul 16 '13 at 23:21
    
Note that you may need to look for langs.xml in %APPDATA%\Notepad++ (rather than the program folder). –  Sygmoral Feb 14 at 17:01

Go to Settings > Styler Configurator. Choose XML from the left-hand scroll list. In the bottom of that dialog, there should be two boxes - one for default extensions and one for 'user extensions'. Add your .config to the 'user extensions' box and click 'Save and Close'.

NOTE: The 'user extensions' might not be available for all language choices (I KNOW it is available for C, since that's the syntax highlighting I use at work). So, if it is not available, you'll have to create your own language file.

share|improve this answer

This is how I did it:

Navigate to %APPDATA%\Notepad++ and open the langs.xml file

Find a node like the one below and add "config" as shown

<Language name="xml" ext="xml xsml xsl xsd kml wsdl **config**" commentLine="" commentStart="&lt;!--" commentEnd="--&gt;" />

Restart Notepad++ Open a .config file. It should be formatted as XML.

And also make sure you don't have any other conflicting settings, i.e. anything else mapped to .config files

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.