Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My home router provides Web server here: 10.1.1.1:80

I can ping and connect to it fine with a web browser. For whatever reason, I want to establish a connection to its web server via telnet too.

I have installed telnet on windows 7. I run cmd as admin. I run telnet, and set localecho. I then open 10.1.1.1 80

The result always leads to the connection not occurring:

Welcome to Microsoft Telnet Client

Escape Character is 'CTRL+]'

Microsoft Telnet> open 10.1.1.1 80
Connecting To 10.1.1.1...

Connection to host lost.

I have used wireshark to confirm that an exchange of packets between the telnet client and the webserver was in fact occurring to rule out any firewall issues (there was no payload, but the server was sending back ACKs). Am I missing something? Why can't I submit HTTP commands?

I want to know how to use telnet to send and receive the http requests. For reasons outside the scope, I have to use telnet as the tool.

EDIT: I think telnet is working ok but the server is just disconnecting too quickly for me to submit any HTTP commands. I tried with a number of servers and noticed that, in most cases, there is no feasible way to submit a command (i.e. the connection is lost before a single key press can be made). So I suppose what I should have asked (updated the title accordingly) is:

(a) why is it lost so quickly?

and

(b) what can be done to either not lose the connection or submit a command before the connection is lost?

share|improve this question
1  
Have you tried using port 23? –  ekaj Apr 24 '13 at 0:22
    
I am not trying to make a telnet connection, I am trying to test the web server on port 80 using telnet. Sorry I should have made that clearer. –  rafraf Apr 24 '13 at 0:34
    
How long of a period is it between Connecting To 10.1.1.1... and Connection to host lost. –  Scott Chamberlain Apr 24 '13 at 0:37
    
Almost instant. I get a Press any key... almost as soon as it forms the connection. In fact, I can see in wireshark that it is 1.1 seconds. That is from first packet to last. –  rafraf Apr 24 '13 at 0:38
    
Are you attempting the telnet operation from a machine on which http://10.1.1.1/ is 100% known to work? –  David Schwartz Apr 24 '13 at 0:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.