Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I moved this question from Unix/Linux SE, since I think it fits here best.

When I alt-tab in Kubuntu 12.04, the listed windows are from the current screen only. In the Task Switcher settings, the "List windows" option is set to "All desktops", a setting which I changed a couple of times just in case it gets fixed, but with no luck.

It used to list all windows in the past. Since then:

  • I changed the effect options (listed in Task Switcher) a month or two ago
  • I applied several updates (system-wide, as in apt-get update/dist-upgrade )

but I cannot say for certain when the problem first occured.

Any suggestions?

share|improve this question
up vote 0 down vote accepted

I found out that disabling "Separate screen focus" in KDE's Window Behavior solves the problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .