Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My notebook is Asus U46E has one USB3 port. I tested the write speed of USB3 in Ubuntu, it's fast as my expectation without doing anything. But when I go to Win8, the data was written in not-right-speed of USB3. I had tried to install drivers from Asus. It's still the same.

EDIT: In the benchmark, I see the read speed is good. Write speed did not pass 15MB/s.

p1 Drivers p3 p4 bmark

Any suggestion?

share|improve this question

Try the latest driver version 3.5.97.0 from here:

http://www.station-drivers.com/page/fresco_logic.htm

And I also have this USB controller and I can say that this one is a 1st generation controller which has some issues (that's why MS doesn't use the new USB 3.0 drivers from Windows 8 for this USB controller).

Maybe the Linux drivers have fixed the issues and that's why you see the good speed.

share|improve this answer
    
I have installed the latest one from Fresco. But I still got the same issue. I hope they can fix this soon. – anhtran Apr 24 '13 at 4:31
    
look if you have activated the Write Cache in the device manager for your USB 3.0 device. – magicandre1981 Apr 24 '13 at 4:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .