Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to enable passwordless sudo for user "bamboo" on my host, so I have added

bamboo ALL=NOPASSWD: ALL

and also

%admin ALL=(ALL) NOPASSWD: ALL

(user bamboo is in the admin group) to the /etc/sudoers, logged out, logged in, but the sudo still asks for a password. I am on "Ubuntu 12.10" ... Any idea what do I wrong?

Thanks, f.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You have different mistakes in each line: On the user ilne, you have not specified the COMMANDS portion, should be:

bamboo ALL=(ALL) NOPASSWD:ALL

On the group line, you used admin instead of admins:

%admins ALL=(ALL) NOPASSWD:ALL
share|improve this answer

From ubuntu forums I found this link which says:

Administrators are added to the sudo group, but the admin group is supported for backward compatibility.

So you should have sudo group at /etc/sudoers and you should enable this line:

%sudo ALL=(ALL) NOPASSWD: ALL
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.