Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For about 5 days now, our Internet connection has been doing something unusual. These are the kinds of symptoms that usually indicate a bad network card, or something wobbly with a wi-fi router but this feels like a provider issue. I'd really appreciate any advice in the period between now and when we can get a technician to come out...

I have about 12 (sorry, I always lose count) devices on wi-fi (spread between 2.4Ghz and 5Ghz. I also have an Ubuntu machine connect directly to the router. Every device achieves great results using any of the various speed tests, even when connecting to servers in New York (we're in California). We get about 27 down and 5 up, which is good considering we're paying for 25/5.

My family started to notice about 5 days ago that streaming was sucking big time. Netflix would get to about 2 minutes into a movie and buffer. YouTube does the same thing, and the only way to get it going again is to click further down the timeline... until it hangs again. Altering the quality on YouTube makes zero difference. On top of all that, I've noticed that streaming from iTunes or iTunes Match is highly temperamental. Even Pandora quits halfway through songs and starts another song. Downloading anything from iTunes is useless, and even updating apps on my phone only successfully completes when I switch to 3G.

So, I gave it a few days hoping it was just a temporary glitch. These things happen occasionally, and we had a few days of slowness about two months ago. In fact, it was at that time that I decided to ditch our two aging wi-fi routers (8 and 9 years old!) and fork out for a Gigabit N900 router. The Asus RT-N66U has been fantastic from the start. I had a run-in with a terrible D-Link router that went back after two days, but I'm impressed with the "Dark Knight" (the corny name Asus gave their amazing router).

Well, tonight I decided to get serious about these weird problems. I started by trying to play a song on our Apple TV. No dice. It stopped at 2:12. The really bizarre thing was that when I played the same song on a MacBook and on my phone... it also stopped at 2:12. Then I decided to try a file download on Ubuntu. I picked an ISO image (763Mb) and noted that it stopped at 19.8Mb. I tried again with wget. Every time, it quits as follows...

0% [                       ] 1,979,094   --.-K/s   in 15m 2s

Notice that the point where it stops is always at the 19.8Mb mark. Really bizarre. And trying on different machines ad platforms yields the same result down to the byte.

Cut to a quick speed test (one of many I've done these last few days)... 27.44Mbs down/4.80Mbs up.

Also, note that nothing has been changed on the router (and I know of nothing that would cause this). QoS is turned on. The only real change from the factory defaults is MAC filtering which has been set up since the night I brought it home.

So... great peoples of superuser, is there anyone out there with insight into this oddity, or is this something that Comcast will have to figure out? Let me know if there is anything else I can provide. I just had to call Comcast three times before their system dropped me off at the right department so I'm a little on edge.

Edit: I switched out the Cat 5e cable from the MODEM to the router: no difference. :(

Just for fun, here are some more wget results. Different ISO. Same stall point each time!

3% [                       ] 32,324,829  --.-K/s  eta 36m 37s

3% [                       ] 32,324,829  --.-K/s  eta 56m 12s

3% [                       ] 32,324,829  --.-K/s  eta 3d 2h

That last one is my favorite!

share|improve this question
up vote 2 down vote accepted

So... putting all the pieces together...

  • No Router at all, single device direct to modem, downloads stop at somewhere under 10%. This is regardless of the device you connect directly to the modem, or did you only perform this test with one device?

  • QoS is on with the new router, but this problem is independent of the router since it occurred before replacing the old equipment. Correct?

  • The problem occurs with all of the varied devices connected to the network. So the only common piece of equipment is the modem itself.

Diagnostically speaking, if these things are true, I'd say the issue is with either the modem, or with Comcast. I realize you performed speed tests, but speed tests use small files that could be completing their transfers. You have noticed that after a download has started and been allowed to run for a short period of time, it will stall. There is some transfer of data. Your connection appears to work in bursts, which would allow a speed test to appear normal, provided the small files it uses transfer in those small bursts.

You could simply request a new modem, or you could request a Comcast technician come to your home to repeat your simplest test... a single device connected directly to the modem. Even a marginally competent technician who was suspicious of the device you used for the test should be able to repeat your results with his own equipment.

share|improve this answer
That's exactly right. Comcast came this morning, fumbled about, made a quick call to HQ... and BLAM! Everything back to normal. It's kinda the conclusion I already reached, but since I've had fun with two dead(ish) MODEM's and a couple of fishy routers in the past I just wanted some reassurance. When push comes to shove, connect something up to the MODEM directly, and if you see the same nonsense, you know it ain't your router. Confirm with two or three other computers and you know it ain't your equipment at all. – Ian Atkin Apr 24 '13 at 16:13

have you looked at your traffic graph, at the RT-N66U , check if you are maxing out on your bandwidth?, also you can run some ping and trace-route to find our where your traffic goes, and if there is any major packet loss on any segment. Finally look in your ISP contract, do you have any limitations on Downloads per month? you can also try to unplug everything, and connect only one device to the RT-N66U and test the line with only one host. and maybe change your wifi password, in case your neighbors are catching a ride on your network. that is all I can think of at this stage.

share|improve this answer
Let's go through the list... traffic graph is inconclusive as the stall point seems to be a percentage of total file size and not any particular ceiling. traceroute is interesting as it seems to hit no less than 6 nodes at Comcast before going out... and it was veeery slooow. We have the usual limits in our contract, but surely it'd be all stop if we hit them (but it's something to look into). As for diagnostics, I've done all the usual steps, starting with a single device hooked up directly (no router). There was no difference at all. – Ian Atkin Apr 24 '13 at 8:17
Thanks for your list of things to try. It's easy to forget some things in a fit of frustration. I'd give you a green check also if I could. – Ian Atkin Apr 24 '13 at 16:14
I guess the next step is to talk to your isp... sorry. – Sverre Apr 25 '13 at 9:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.