Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

FIRST: I know this same problem has been discussed, but I have tried things and haven't found anything regarding Super Grub 2 and such.

Well the issue is pretty much defined in the title, but to be more precise:

System boots up and let's me go in the BIOS or Boot Manager. After that it boots to a black screen with a blinking cursor but it doesn't go past it.

Now the funny thing is that if plug in my UBS stick with Rescatux installed (Rescatux + Super Grub 2 Disk) and choose Super Grub 2 Disk and then there choose Detect any GRUB2 configuration file (grub.cfg) it leads me to a menu with (hd1,msdos1)/boot/grub/grub.cfg and let's me boot into Ubuntu.

My specs are as follows:

Intel HM76 board
nVidia GT650M
8GB 1600Mhz RAM
First HDD: 120GB Kingston V300 SSD (has Ubuntu not partitioned)
Second HDD: 500GB WD Scorpio Blue (has 8GB as SWAP and the rest as an unmounted EXT4 partition)

Edit: BIOS version is InsydeH20

Edit 2: I've also tried to install GRUB on my second hard driver, but no luck booting.

What seems to be the issue is that I can boot from a USB stick but not from an HDD, any tips?

share|improve this question
This may be an obvious question, but have you tried changing your boot device to your other hard drive? If it was a grub issue then you'd get the grub rescue prompt, and since your usb finds it that may just be the case. – nerdwaller Apr 24 '13 at 14:24
@nerdwaller tried it! thank you anyway – Ricard-Sole Apr 24 '13 at 14:25
Are you dual booting? If you have another OS that's UEFI (or you board set to boot UEFI only) grub needs to be installed differently for the boot process to catch it. Just another thought... Reference this if that may be the case, I've also used Boot Repair to fix similar issues. – nerdwaller Apr 24 '13 at 14:30
Just booting Ubuntu, no Windows or any other distro installed. – Ricard-Sole Apr 24 '13 at 14:32

I would suggest you to:

1> disconnect all other hard drives, and leave the one you wish to install grub2 on.
2> boot off a livecd such as RIP linux ( latest has grub2 setup available )
3> re-install grub on your primary ( and only ) disk
4> if you able to get to grub after rebooting, add the rest of secondary drives and set them properly in the bios ( under boot priority/sequence )

share|improve this answer
That would've probably worked, but I did it in a different way. Thanks though. – Ricard-Sole Apr 26 '13 at 9:35
up vote 0 down vote accepted

Finally solved it (probably not the best way to do it, but who cares!) and here's how I did it:

  1. 1- Plug in Super Grub Disk2 and boot into Ubuntu
  2. sudo apt-get install multisystem
  3. Once there it will ask you where to install GRUB2 (don't ask me why)
  4. I choose to install it on every disk but the usb drive.

And you are done!

Hope this helped some one.


The right way to do this is:

sudo apt-get purge grub-pc grub2
sudo apt-get install grub-pc grub2

Here we choose to install it on every disk available (just in case)

sudo reboot
share|improve this answer
  1. Boot with Super Grub2 Disk or Rescatux

  2. Browse the options of the boot disk trying to boot your installed Ubuntu

  3. Once you get the login screen enter to the system and run this sudo update-grub

  4. Reboot

If that don't worked do the same steps, but after step 3 do this:

run mount

You will get a list with mounted devices. You need to look for the one which says where is mount the / directory; something like /dev/sda1 on / type ext4 (rw,errors=remount-ro).

Take care with this, and re-read it until you understand it.

We were looking for the /dev/sda1 part, but it can be /dev/xvda1, or /dev/hda1 or with a different number like /dev/sda5.

Remove the last number /dev/sda1 -> /dev/sda.

Run this: sudo grub-install /dev/sda

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .