Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed spf13-vim on my Vagrant machine with Ubuntu.

The issue is that when I log into Vagrant with vagrant ssh and run Vim then I get all these upside down question marks on either making a space or a tab.

In ~/.vimrc I've got:

scriptencoding utf-8
set encoding = utf-8
set termencoding = utf-8

share|improve this question

migrated from stackoverflow.com Apr 24 '13 at 15:03

This question came from our site for professional and enthusiast programmers.

2  
There must be no spaces around the = assignment in :set, but I doubt that's your problem, since it would cause visible errors. –  Ingo Karkat Apr 24 '13 at 9:40
    
Why would you use set encoding = utf-8? It's seems safer to just set it in your LOCALE, so you still can edit non-ascii/UTF files like ISO8859-1 without breaking them. –  timss Apr 24 '13 at 12:32
    
timss: You may be misunderstanding what the 'encoding' option is for. You can set it to "UTF-8" safely without risking damaging files, as Vim has a 'fileencoding' option as well. –  Heptite Apr 26 '13 at 1:31
    
I'm experiencing this same issue –  user1027169 Apr 29 '13 at 18:01

1 Answer 1

I guess you can try :set nolist which tells vim not visually list space-like characters. You can check :h 'list', :h 'listchars' for further reference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.