Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My xslx files open systematically with Excel 2010 when I'd like them to use Excel 2013.

Everytime I

  • right click
  • select open with
  • point to C:\Program Files\Microsoft Office 15\root\office15\EXCEL.EXE

Then Excel 2010 (aka, office 14, not office 15) launches instead of Excel 2013 (Office 15)

The same problem appears on 2 colleague's desktop.

Has anyone encountered that ? Is there a workaround ?

share|improve this question
    
I assume that getting rid of Office 2010 is not an option. –  Ramhound Apr 24 '13 at 15:21
    
Also experienced this problem on Win7. Parker's solution fixed it for me. –  Darthfett 2 days ago

6 Answers 6

up vote 9 down vote accepted

I had the same issue, this solved it :

Control Panel > Programs > Uninstall a program > Select MS Office 2013 > Change > Quick Repair

share|improve this answer
    
interesting. thank you for taking the time to share back. –  nicolas Jun 11 '13 at 8:17
    
Just a note in case others find this looking for a win7 fix: I tried this to solve a problem with 2007 vs 2013 on Win7 (the only difference is "repair" versus "quick repair") and it worked as well. –  panhandel Sep 26 '14 at 16:24

I have not verified this but this post documents using a batch file to control this for 2003 and 2010. Modified for your case it should be something like:

Open a command prompt and navigate to Excel 2010 directory

"c:\program files (x86)\Microsoft Office\Office14\Excel.exe" /unregserver

Then navigate to the Excel 2013 directory and re-register 2013

"c:\program files (x86)\Microsoft Office\Office15\Excel.exe" /regserver

share|improve this answer
    
yes I think the only way is to mingle with the registry. how pathetic. –  nicolas Apr 24 '13 at 15:33
2  
@nicolas - To be fair Office has never really supported multiple versions of Office being installed. This behavior likely would extend to office 2007 and Office 2010. Depending on the license source you might even per the license not allowed to have both versions installed. I know my Office license doesn't allow both versions to be installed. I am just to lazy to uninstall Office 2010 from my system. –  Ramhound Apr 24 '13 at 15:40
    
@Ramhound I would consider "fair" that my computer launches the program I instruct him to when I explicitly tell him which one he should launch. i think it is quite dubious to imagine that a legal binding would temper with mechanism which are not meant to enforce a legal contract. –  nicolas Apr 24 '13 at 15:48
    
@nicolas - I only pointed out that Office has likely always required to re-register if multiple versions of Office are installed. Of course since I installed Office 2010 after Office 2013 I didn't end up with this problem. –  Ramhound Apr 24 '13 at 16:10
    
@Ramhound I dont know what you mean by 'register': legal status like you mentioned ? registry ?, or 'supported' (no clue) . I dont understand why you mention you have 2010 and 2013 installed either. –  nicolas Apr 24 '13 at 16:27

Once you right click on the file, you go to Open With > Choose Default Program > "C:\Program Files....\excel.exe it should open every time without a question.

share|improve this answer
    
are you a windows 8 user ? –  nicolas Apr 24 '13 at 15:19
    
@nicolas - Doesn't matter it works on Windows 8. –  Ramhound Apr 24 '13 at 15:20
1  
@Ramhound why do you think I ask ? –  nicolas Apr 24 '13 at 15:32
1  
Did you read the actual question that was posted? They did exactly what you are advising but it is not working. It is very perplexing but when you select the office 2013 excel it still opens with office 2010 excel. I would down vote you if i had the rep for it. –  Nick Sotiros Jun 30 at 22:38
    
@NickSotiros First and foremost, this post was from like 2 years ago. Secondly, I DID read the question. If anything, you need to work on your reading comprehension skills. He said that he used right-click, Open With, excel.exe... In my post I bolded "Choose Default Program" because that's how you change the default application for the extension that you're trying to open. This user seemed to be experiencing a different issue in which the marked accepted answer was the solution to his problem. –  Chris 2 days ago

I too have a similar issue where I have an Excel addin that I need to use that is only supported on an older version of OFfice because Microsoft keeps changing the VB coding (Office XP in this case), and I have Office 2010 which I prefer to use most of the time for everything else. On Windows XP, Vista, or 7, I have successfully used both versions of Excel with out a hitch. On Windows 8, it will not allow me to "open with" the alternate version of Excel. You "open with" and you point to the Office 14 Excel 2010 directory and it associates with Office XP anyways...because it was installed the latest... only one or the other. Lame. The only way around it that I know is to manually open the version of excel, and then File->Open to the directory of the file.

share|improve this answer
  1. Select any spreadsheets using windows explorer

  2. Right click on the file

  3. Select Properties

  4. Select "Change"

  5. Selcet your Excel Application

  6. Done!

share|improve this answer
    
Did you read the whole question? This is what the OP did and it doesn't work. I am having the same problem and changing the association is not working as it should. –  Nick Sotiros Jun 30 at 22:34

Go to Start > Control Panel > All Control Panel Items > Default Programs > Set Default Programs >Select Excel(Desktop) on Left side of the pane Then click on Set this program as default > OK.

share|improve this answer
2  
This does not work when trying to switch from 2010 to 2013, under win7. I can see two entries for Excel but selection either leaves me with Excel 2010 as default –  JustinJDavies Aug 9 '14 at 0:07
    
I can't gt this to work either. There is no Excel(Desktop) available at all. I think the problem is in the registry. –  Nick Sotiros Jun 30 at 22:41
    
@JustinJDavies In my installation I could only see the 2013 version, and it still left it with 2010 as the default. –  Darthfett 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.