Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ASUS K55VM laptop which has 2 USB 3.0 ports. I'm running on Windows 8 x64. When I use plug in a USB 3.0 external hard drive from any 1 of the USB ports I get write/read speeds of only ~25MBps. This opposed to my other laptop (Dell XPS with USB 3.0 ports also running on Windows 8 x64) gets ~100MBps.

I have also searched for installed the relevant drivers for my ASUS laptop.

Intel points out the following: USB 3.0 Support

Here's the link to the FAQ Intel article: USB 3.0 devices are not working at USB 3.0 speed in Windows 8*

In the second link, I do not understand the cause. I have included a picture of the device manager for reference.

enter image description here

Here's a picture of the external hard drives in question. It's a Toshiba Canvio 1TB.

When I plug it onto the ASUS one, notice that the light glows WHITE.

enter image description here

When I plug it into the DELL one, notice that the light glows BLUE indicating that it is functioning in true USB 3.0 mode.

enter image description here

share|improve this question
    
have you activated write caching in device manager? –  magicandre1981 Apr 25 '13 at 3:59
    
Write Caching was disabled by default. That didn't help as it turns out on both the laptops, it was running on the default setting. –  Abhishek Sha Apr 25 '13 at 16:05
    
Any suggestions? –  Abhishek Sha Apr 26 '13 at 19:51
    
look, if there is firmware update for the HDD –  magicandre1981 Apr 26 '13 at 20:35
    
^ This cannot, seriously, be the solution. There is no firmware, just checked. –  Abhishek Sha Apr 28 '13 at 6:58
show 1 more comment

1 Answer

up vote 3 down vote accepted
+50

Ensure first that you have installed the latest BIOS, then read further if the problem still exists. Check carefully that the linked version is later than the one you have.

From Windows 8 and Intel USB 3.0 Host Controllers :

One of the new features of Windows 8 is the built in XHCI host controller software and USB stack. While this brings some benefits like UASP support, there are some devices that currently don’t work with the Microsoft stack on the Intel USB 3.0 host controller. This can be fixed by forcing Windows to use the Intel USB 3.0 host controller drivers instead of the built in stack.

The article then describes in great detail how to force the installation of the Intel USB 3.0 eXtensible Host Controller Driver. The download link it gives to the Intel site will contain the latest version, rather than the one mentioned in the article.

However, before executing this, I suggest to ensure that you have backups, at least creating a system restore point (but even better is taking an image of the system disk).

share|improve this answer
    
Thank you! The instructions worked perfectly. For a while there, I was getting true USB3.0 speeds. Until I restarted my laptop. Now, even though the Intel drivers have been installed, I'm back to my previous state of not getting true USB3.0 speeds. Any suggestions? –  Abhishek Sha Apr 30 '13 at 9:02
    
(1) Check if there is a newer version of the chipset driver on the Asus site, (2) Always reboot Windows without driver signature enforcement or the Intel drivers will be ignored (this is a security hole but necessary), (3) If you repeated the above installation and it still doesn't work after reboot, then it means that Win8 redetects the usb3 as its own on reboot so you will probably need to uninstall the Microsoft driver (which I don't know how to and don't recommend), (4) You could get in touch with Asus Support. –  harrymc Apr 30 '13 at 10:38
    
^ Yes, that was the probelem. I have found a work around to keep the driver sign enforcement always disbaled. Type this in an elevated command prompt: bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS bcdedit -set TESTSIGNING ON To turn it off again, use these commands: bcdedit -set loadoptions ENABLE_INTEGRITY_CHECKS bcdedit -set TESTSIGNING OFF –  Abhishek Sha May 1 '13 at 8:46
    
With a bit of luck, in the future Microsoft may resolve its usb3 problems or Intel may sign its drivers for Win8. Keep looking for updates of both, so you could re-enable driver signature enforcement. –  harrymc May 1 '13 at 9:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.