Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I try to install any driver(I tried Vmware, Virtualbox and my webcam driver) I get the error

Not enough storage is available to process this command

I tried increasing the IRPStackize as specified here, however that KB is about transferring files from a server to client and this is about drivers.

The error message from Event Log, I have 20 GB of free space on my C: drive

Fault bucket , type 0
Event Name: PnPDriverInstallError
Response: Not available
Cab Id: 0

Problem signature:
P1: x86
P2: 00000008
P3: vmci.inf
P4: 4af0eded3adeeb65b553b084abbaf45d0c5cd514
P5: vmci.install
P6: 
P7: 
P8: 
P9: 
P10: 

Attached files:

These files may be available here:
C:\Users\Gowtham\AppData\Local\Microsoft\Windows\WER\ReportQueue\NonCritical_x86_b8ae86859f991067eed5448ac3c07952d21e583_0a6d56f5

Analysis symbol: 
Rechecking for solution: 0
Report Id: 74c97360-ad5c-11e2-bf8d-bcaec599c7f1
Report Status: 4

Looking at the driver install log, I found this

>>>  [DIF_INSTALLDEVICEFILES - ROOT\*6TO4MP\0000]
>>>  Section start 2013/04/25 13:31:37.843
      cmd: C:\windows\system32\svchost.exe -k netsvcs
!!!  dvi: Unable to open file queue
!!!  dvi: Failed copying driver files (00000008)
!!!  dvi: Error 8: Not enough storage is available to process this command.
!!!  dvi: Default installer: failed!
!!!  dvi: Error 8: Not enough storage is available to process this command.
<<<  Section end 2013/04/25 13:31:37.845
<<<  [Exit status: FAILURE(0x00000008)]
share|improve this question
    
Do you have system restore on? Perhaps it's trying to do a restore point and erroring? –  nerdwaller Apr 25 '13 at 4:14
    
Yes, system restore is on but how could it be related to this, I will try to install again after disabling System Restore. –  HackToHell Apr 25 '13 at 4:15
    
I know it seems like a stretch, but I have had all sorts of odd things happen with lowish drive space and it on. Probably not your issue, but thought I'd point out the obscure since your rep suggests you'd try most normal things. –  nerdwaller Apr 25 '13 at 4:24
1  
@nerdwaller Gonna free up another 10 gb or so and will see if this happens again –  HackToHell Apr 25 '13 at 4:41
    
@nerdwaller cleaned up some 20 gb of data, problem persists –  HackToHell Apr 25 '13 at 5:08

2 Answers 2

up vote 1 down vote accepted
+50

Your Windows installation seems to be in a particularly bad shape.

If this problem is not too old and you have a system restore point from before that, I suggest that you try to go back to a time that Windows was more stable.

Otherwise, boot in Safe mode and see if the problem is still there. If not, then some installed product is causing the problem and you need to find out which.

If this is also happening in Safe mode, then something is seriously wrong with Windows.

The next step is to try sfc /scannow and let us know what the result is.

The last stop before reinstalling Windows is Repair Install, that should fix Windows while preserving user accounts, data, programs, and system drivers.

share|improve this answer
    
Looks like Trusted Installer has messed up some dlls while trying to install a update, looks like I have to repair install >.< –  HackToHell Apr 28 '13 at 10:17
    
One explanation might be the forced installation of a 32-bit driver on 64-bit Windows. The last time this happened to me I had to restore the system disk from an image since nothing worked any more and the driver couldn't be uninstalled. Whatever you installed that caused this problem, I suggest skipping next time. –  harrymc Apr 28 '13 at 12:58

This error is caused by low RAM memory.

Try to increase the RAM or try it in an other PC that has more ressources.

share|improve this answer
1  
Added 2 more gigs of ram and the issue persists –  HackToHell Apr 25 '13 at 8:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.