Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed oracle VM virtualBox on Win7,then I downloaded android-x86-4.2-20121225.iso from Android-x86 - Porting Android to x86.After I installed Android x86-4.2 on VirtualBox from iso and creating fake SD Card for it,I tried to run it,but when I started it I saw these lines in console:

Detecting Android-x86... found at /dev/sda1

ANDROID root@x86:/ #

And no thing else.I tried that some times but result is the same.How I can solve this problem?

Update: Even I waited more than 20 minutes and nothing happen!

share|improve this question
up vote 5 down vote accepted

You just need to change the value of "androidboot.hardware" parameter in the grub command from "Android-x86" to "x86". You can do this by pressing "Tab" in the boot menu or by editing "isolinux.cfg" file on the installation ISO Image.

Hope this works for you.

share|improve this answer
    
Thank you,that works for me!Although it takes some times. – hasanghaforian Apr 25 '13 at 19:21

I have an HP430 Laptop with Windows 7. I had the same problem. But I figured out the solution:

While booting the computer with Windows 7 I entered the BIOS menu. There was a option to optimize the PC for virtualization. I selected it. After that every thing ran smoothly.

Later I noticed that in VirtualBox, in system settings, the acceleration type was VT-x AMD, Nested Paging, PAE/NX. This was different before optimization.

share|improve this answer

You have to wait more. I think it will start, but you have just wait enough.

share|improve this answer
2  
It's more likely that there are no graphics drivers in the recent ISO image. Official VirtualBox support is non-existant since ICS. – Stefan Seidel Apr 25 '13 at 8:21
    
@RistoSalminen I wait more than 20 minuets and no thing happen! – hasanghaforian Apr 25 '13 at 9:27
    
Oh, that's sad. Then you have more serious/hard problem. – Risto Salminen Apr 25 '13 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .