Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Apologies for misusing some terminology here... I'm attempting to fix a friend's laptop (Dell Inspiron 1545) which was suffering from the error "disk error press any key to restart" on every boot, straight after POST. (Not intermittent, I always received the error).

I tried the drive (250GB SATA) in another machine, and used Window's disk management console to see that it recognised the drive as having 3 partitions.. one was the recovery NTFS partition which seemed perfectly fine, another was the OS partition which was displayed as RAW. It had a drive letter assigned but I could not access the data.

So I tried the program TestDisk which seemed to display the partition as NTFS.. I did nothing but quick scan/save however that has had no effect.

I'm not sure where to go from here.. should I be able to tweak the settings/findings in TestDisk? or should I give up? I can recover the data using Recuva pretty well - but as it's a friend's machine it would be great if a simple fix for the partition table would bring the whole machine back to life as it was.

Does this screenshot help? It shows the findings of TestDisk... http://i.imgur.com/cW0YrM3.jpg

Many thanks for any pointers you can give :)

EDIT

After running a deep scan with TestDisk, it provided the following summary http://i.imgur.com/b242Czv.jpg. Looked slightly odd, but I saved it and now windows doesn't give either the OS or the Recovery partition a drive letter. Does the summary give any suggestion as to how I could proceed? maybe the start/ends are correct but the partitions shouldn't be split in two? Or maybe it's time to give up and format :D

share|improve this question
    
When it comes to data recovery, nothing is ever simple. That said, I've had pretty good luck with TestDisk ability to recover lost partitions. – mvp Apr 25 '13 at 9:36
    
When using TestDisk - do you just stick to the semi-automated Scan/Save process - or is there anything else if that fails to work? I haven't done the deep scan so maybe I need to try that first.. – Tabloo Quijico Apr 25 '13 at 9:42
    
I did deep scan - it takes a while, but seems to find partitions reliably even if you dd start of disk with 0's. – mvp Apr 25 '13 at 9:47
    
Thanks, have added further comments in the original question. – Tabloo Quijico Apr 26 '13 at 9:17

I've been consistently successful with Spinrite. As long as it's not a mechanical problem, it works really well.

HTH

share|improve this answer
    
Thank you for the suggestion - I should have maybe said in the question but I'm not looking to pay for any solution but just stick to the free options. It's more an educational exercise really :) – Tabloo Quijico Apr 26 '13 at 9:16
    
Please let us know how it goes, I haven't been able to find an alternative free solution.. – Pedro Bezunartea López May 8 '13 at 20:52
    
Pedro - please see my answer, maybe mine was a very simple case but chkdsk did the trick! – Tabloo Quijico May 12 '13 at 20:29
up vote 0 down vote accepted

I was probably overthinking this issue a tad. All I had to do was run a chkdsk /f and it fixed the problem, drive now appears with files accessible :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .