Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A while ago, I added a number of context menu commands to import Kindle books into Calibre and convert them to EPUB (under HKEY_CLASSES_ROOT\Amazon.Kindle.content). All associated extensions are set in the registry to point at Amazon.Kindle.content. This has been working great up until today, when the commands stopped showing up for .mobi files. When I right click a .azl, .azs, .azw, .azw3, .azw4, .prc or .tpz file, they appear and work as expected. But not for .mobi. Here are my registry entries for .azw and .mobi — they look exactly the same to me so I have no idea what is going on:

[HKEY_CLASSES_ROOT\.azw]
@="Amazon.Kindle.content"

[HKEY_CLASSES_ROOT\.mobi]
@="Amazon.Kindle.content"

jscholes@rebus:~$ cat >azw.reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.azw]
@="Amazon.Kindle.content"

jscholes@rebus:~$ cat >mobi.reg
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.mobi]
@="Amazon.Kindle.content"

jscholes@rebus:~$ diff azw.reg mobi.reg
3c3
< [HKEY_CLASSES_ROOT\.azw]
---
> [HKEY_CLASSES_ROOT\.mobi]
share|improve this question
    
Have you tried deleting and re-creating the keys for mobi? Did you install anything recently that might have associated itself with the extension? – Karan Apr 25 '13 at 15:45
    
Yes. So far, I've tried: Deleting and recreating HKEY_CLASSES_ROOT\.mobi; doing the same for other Kindle-related file extensions; removing and restoring my additional commands in HKEY_CLASSES_ROOT\Amazon.Kindle.content; and reinstalling Kindle for PC (which creates the file associations in the first place). In Windows Explorer, when focussed on a .mobi file the Type column shows "MOBI File." When focussed on a file with any of the (working) extensions it shows "Amazon Content." I don't understand why .mobi files aren't being appropriately associated. – James Scholes Apr 25 '13 at 15:52
    
See my own answer. I don't really understand why that solution worked, but glad the problem is fixed. – James Scholes Apr 25 '13 at 15:58
up vote 0 down vote accepted

The solution, which I probably should've tried sooner, was to set the default program for .mobi files to Kindle for PC. Nothing has been altered in HKEY_CLASSES_ROOT.mobi after doing this, but the commands now show when right-clicking a .mobi file.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .