Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm trying to paste text from Word (or even other MSFT applications) that use an apostrophe (') or double-quotes (") into a PuTTY session, the apostrophes or double-quotes get turned into periods (.). The characters are definitely some different character in Word, since I can paste it into Notepad++ and it shows up as a more stylized apostrophe, rather than the straightforward (').

I'd like to figure out how get PuTTY to convert that stylized apostrophe into a normal apostrophe when I paste into it, rather than PuTTY converting it into a period.

Is there a setting in PuTTY to do this?

share|improve this question
1  
Why not simply turn smart quotes off in Word instead? – Karan Apr 25 '13 at 15:01
    
If I was creating all the docs myself, I would. Also, this seems to be an issue when pasting from other applications, not just Word, so I'd like a setup that can catch those characters, regardless of what application I'm pasting from. – garettmd Apr 25 '13 at 15:05
    
If Putty can't do this, you can set up an AutoIt/AutoHotkey script that will sanitise your clipboard contents on demand before pasting. – Karan Apr 25 '13 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.