Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a dual-screen set-up with a Windows host and a Linux virtual machine.

Windows Host: Windows 7 x64, VMware Workstation (8.0.5, most recent)
Linux VM: CentOS 6.4 x64 (most recent) + VMware Tools (most recent)

The shared clipboard feature is of great importance to me. I often copy commands from the Windows host into the Linux VM, but clipboard sharing often stops working.

A reboot of the guest does not solve the issue. A reboot of the Windows host machine does solve the issue, although it's only a temporary measure. The issue often comes back within 20-30 minutes after reboot.

share|improve this question

migrated from Apr 25 '13 at 19:44

This question came from our site for professional and enthusiast programmers.

Same here. Windows 7 x64 host, VMWare Workstation 9.0.2. VM Windows XP + appropriate VMWare Tools. Though, haven't found yet dependency between issue appearing, disappearing and reboots. – Andriy K Jun 14 '13 at 17:10
Same issue - Windows 7 x64 inside Windows 7 x64. Random. Very random. – Neolisk Jan 23 '14 at 19:47
Since you are running a Linux VM I have to ask. Are you using the genuine VMware tools that you compile? Or are you using the OpenVM Tools? While many people have told the difference between the two is slim to none I have had very very few problems when I am using the "roll your own" VMware tools. If you are not I would recommend trying that first and see if it resolve the issue. – ianc1215 Feb 4 '14 at 4:25
Also while slightly off topic it is worth mentioning. Are you aware that VMware Workstation 10 has been released. While it would require a paid upgrade there is a chance that a quick look at the changelog could tell you if they resolved your problem or not. Might be worth a look. – ianc1215 Feb 4 '14 at 4:26
I can confirm the issue on Windows hosts and windows clients as well Beginning WS 7.0 all the way now to 10.0.3. During that time I have had Windows Server 2008, Windows Server 2012 as hosts, Windows XP, Windows 7, Windows 8.1, OpenSuse 12.3 as clients and have had the issue on all of them. I haven't had success with the same method all the time but usually completely uninstalling, rebooting and installing vmWare tools resolves the problem. – James Jul 15 '14 at 20:13

10 Answers 10

I once spent a few hours rebooting, reinstalling VMtools, etc., while the fix was really suspending and restarting VMware itself.

share|improve this answer
Suspending? You mean closing and restarting the VMware Workstation? – pabouk Jan 10 '14 at 10:47
I rebooted the guest VM, that didn't work. Then, I repaired VMWare Tools. That didn't work. Then, I simply suspected the guest VM and restarted VMWare Workstation, as @Samgue suggestions, and it worked again. – Travis Spencer Feb 15 '14 at 14:17
Worked! You would think restarting the VM would fix it. However as this answer suggests, suspending and resuming the VM works just fine! – slayernoah Mar 27 '15 at 21:25
This worked for me too on VMware Workstation 11.1.0, thanks! What I did is: Menu > VM > Power > Suspend > (close and restart VMware) > (select VM) > Resume > (copy whatever it was again) > (paste) – Dev-iL May 16 '15 at 20:03
@slayernoah So what works? – technophyle Feb 15 at 3:45

I have the same issue but Host is Windows, guest is Windows. I force kill vmtools and rerun them and that has always made cut/paste continue to work.

taskkill /F /IM vmtoolsd.exe
"C:\Program Files\VMware\VMware Tools\vmtoolsd.exe" -n vmusr

Not sure what the command would be on centos to kill client tools.

share|improve this answer
Worked for me with a Linux host. Kill: /usr/lib/vmware-tools/sbin64/vmtoolsd -n vmusr. Then restart it with vmware-user – freb Apr 20 '15 at 21:33
Heh, I wanted to copy the commands to the guest, but... :) – Paul Aug 15 '15 at 10:25
Didn't work for me running from Guest. – Clay Nichols Apr 12 at 18:54

If running Windows on Windows, try using the VM over RDP. Should be more stable this way. I know this has no relevance to the original question, but some people may find it helpful, because this topic has poor coverage on the internet, with no good solution.

share|improve this answer
Not with an ATI/AMD video card. Expect issues when sleep kicks in on the host. – TombMedia Feb 27 '15 at 18:57
@TombMedia: NVIDIA is a must have. Or built-in. :) I had 3 ATI video cards, they all shared same set of (random) problems. – Neolisk Feb 27 '15 at 19:21

I just restart the VMware services on the host when it happens.

Try avoiding canceling the copy and paste operation. Also only perform one copy and paste operation at a time.

share|improve this answer

This is what worked for me:

Attempt to close VMWare Workstation. You will be prompted with some options on what to do with your running guests (if any are currently running): Suspend, Power Off, Run in Background, Cancel.

Select Run in Background. Reopen VMWare Workstation.

share|improve this answer
this worked for me (I only have to restart VMTools from services on my guest) – Alex Shapovalov Aug 17 '15 at 15:15
This works for me too. I noticed that the problem occurs after I copy something from guest to host, then I can not longer copy from host to guest. This is the quickest fix, everything else has been a waste of time. – KPheasey Jun 15 at 3:04

Had a similar problem with Workstation 10 (W7 host, 2008R2 guest), copying from guest to host didn't work, copying from host to guest did.

Restarting vmtoolsd.exe -n vmusr on guest and vmware-tray.exe on host solved it.

share|improve this answer

Had the same issue with version 10.0.

First make sure Guest isolation is deactivated: VM Settings > Options > Guest Isolation both are enabled.

Try to copy and paste from external HD or removable drives, not from your system partition.

My setup: VM stored on external HD. Copy paste from internal HD (C:) doesn't work, copy and paste from external HD (E:) will work. I assume C&P is deactivated for the local system partition.

share|improve this answer

Experienced it right now on Windows 7 64bit as Host and Guest, VMWare Workstation 9. The solution on my side: The service VMware Workstation Server was set to start manually on the host. After starting this service (and configuring it to start automatically) copy and paste worked normally again between host and guest.

share|improve this answer

In my case simply restarting the VMware tools service in guest resolved this issue (drag and drop of files is working but copying of text via buffer between host and guest does not).

share|improve this answer

The clipboard sharing feature requires that VMware Tools be installed in the your virtual machine. It also enables you to drag and drop between virtual machines and your host OS.

I would say double check to see if VMWare tools are installed. If they are, maybe remove and re-install them. If that doesn't work, you can try updating the VMware workstation. VMWare 9.0 is now available!

share|improve this answer
I believe the question "often stop working" means the tools are installed and randomly stop working. I experience this a lot on my system as well. Seems like a reboot fixes it, but it is annoying as all hell. Host Win7 x64, VMWare 9.02 (it happened in v8 too) with Ubuntu 12.04 VMs – chrisan Jan 1 '14 at 14:16
Workstation 10.0.3 is now available and it still stops working! – James Jul 15 '14 at 20:26

You must log in to answer this question.

protected by Community Oct 24 '14 at 18:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .