Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Firefox as default browser.

Problem: Double-clicking on any internet shortcut in Explorer opens the Print dialog.

Setting for .url under Set Associations is "Internet Browser, Microsoft Corporation".

If I change that setting to Firefox, double-clicking a shortcut gives this error:

http://img38.imageshack.us/img38/9363/screenshot2013042610313.png

What is the correct setting to use here? And what may the cause and solution of this problem?

EDIT:

Top bold right-click option in Explorer is Print. So probably this is a registry problem. Regedit shows the following, where I think something must be wrong?

Shouldn't there be a DefaultAction and OpenWithProgids?

http://img259.imageshack.us/img259/6664/screenshot2013042611375.png

EDIT 2:

Here is the full registry entry. Though I don't know how to reset it, or what to manually change?

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.URL] @="InternetShortcut"

[HKEY_CLASSES_ROOT\.URL\PersistentHandler] @="{8CD34779-9F10-4f9b-ADFB-B3FAEABDAB5A}"

[HKEY_CLASSES_ROOT\.URL\ShellEx]

[HKEY_CLASSES_ROOT\.URL\ShellEx\{000214EE-0000-0000-C000-000000000046}] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\.URL\ShellEx\{000214F9-0000-0000-C000-000000000046}] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\.URL\ShellEx\{00021500-0000-0000-C000-000000000046}] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\.URL\ShellEx\{CABB0DA0-DA57-11CF-9974-0020AFD79762}] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\.URL\ShellEx\{FBF23B80-E3F0-101B-8488-00AA003E56F8}] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

EDIT 3:

Not sure if I'm correct, but I assume .url reg-entry forwards to InternetShortcut? So I post that here:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\InternetShortcut] "NeverShowExt"="" "InfoTip"="prop:System.Link.TargetUrl;System.Rating;System.Link.Description;System.Link.Comment" "EditFlags"=dword:00000002 "FullDetails"="prop:System.Link.TargetUrl;System.Rating;System.Link.Description;System.Link.Comment" "IsShortcut"="" "FriendlyTypeName"="@C:\\Windows\\System32\\ieframe.dll,-10046" "PreviewDetails"="prop:System.Link.TargetUrl;System.Rating;System.History.VisitCount;System.History.DateChanged;System.Link.DateVisited;System.Link.Description;System.Link.Comment"

[HKEY_CLASSES_ROOT\InternetShortcut\CLSID] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\InternetShortcut\DefaultIcon] @="C:\\Windows\\System32\\url.dll,5"

[HKEY_CLASSES_ROOT\InternetShortcut\shell] "CLSID"="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\InternetShortcut\shell\Open] "LegacyDisable"="" "CLSID"="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\InternetShortcut\shell\Open\Command] @="rundll32.exe ieframe.dll,OpenURL %l"

[HKEY_CLASSES_ROOT\InternetShortcut\shell\print]

[HKEY_CLASSES_ROOT\InternetShortcut\shell\print\command] @="\"C:\\Windows\\System32\\rundll32.exe\" \"C:\\Windows\\System32\\mshtml.dll\",PrintHTML \"%1\""

[HKEY_CLASSES_ROOT\InternetShortcut\shell\printto]

[HKEY_CLASSES_ROOT\InternetShortcut\shell\printto\command] @="\"C:\\Windows\\System32\\rundll32.exe\" \"C:\\Windows\\System32\\mshtml.dll\",PrintHTML \"%1\" \"%2\" \"%3\" \"%4\""

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx]

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\ContextMenuHandlers\TortoiseSVN] @="{30351349-7B7D-4FCC-81B4-1E394CA267EB}"

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\ContextMenuHandlers\{FBF23B40-E3F0-101B-8488-00AA003E56F8}]

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\IconHandler] @="{FBF23B40-E3F0-101B-8488-00AA003E56F8}"

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\InternetShortcut\ShellEx\PropertySheetHandlers\{FBF23B40-E3F0-101B-8488-00AA003E56F8}]

EDIT 4:

After running ccleaner (fixing all registry issues) and executed "Set this program as default" for Firefox (under "Set your default programs"), the URL links opens fine in Firefox, as long as that is the default for .URL. However if setting "Internet Browser MS" as default for URL, it still opens Print dialog. And context menus looks like this respectively:

Firefox as default for .URL:

"Internet Browser" (note: not IE) as default for .URL:

Though, if using Internet Explorer as default, it works well:

Perhaps I just should never use "Internet Browser"? Though I would expect that to just direct to the default browser?

share|improve this question
    
Are you opening .png files –  Buscar웃 Apr 26 '13 at 10:57
    
No these are .url, to normal web addresses. –  bretddog Apr 26 '13 at 11:00
    
What is the FF version? –  Buscar웃 Apr 26 '13 at 11:18
    
@Buscar웃 20.0.1, but I've had this problem for a long time. Updated recently directly from 13 (I believe) to 20, and had this issue also with 13. –  bretddog Apr 26 '13 at 11:26
    
The problem seems to be that the default action for url is Print. That's the top bold option when I right-click an url in Explorer –  bretddog Apr 26 '13 at 11:32

3 Answers 3

up vote 1 down vote accepted

You have the Internet Explorer set as default.

And its associations and its defaults.

To change that to Firefox lets do following:

File association

http://windows.microsoft.com/en-us/windows7/Change-which-programs-Windows-uses-by-default

Choose Firefox as browser.

Assign the following protocols and file types to the browser you wish to set as default:

URL:HyperText Transfer Protocol (HTTP protocol)

URL:HyperText Transfer Protocol with Privacy (HTTPS protocol)

URL:File Transfer Protocol {FTP protocol)

HTML File

share|improve this answer
    
what is this ? [HKEY_CLASSES_ROOT\InternetShortcut\shell\print\command] @="\"C:\Windows\System32\rundll32.exe\" \"C:\Windows\System32\mshtml.dll\",PrintHTML \"%1\"" –  Buscar웃 Apr 26 '13 at 12:21
    
Foregive me if I'm wrong, but how is this different from changing specific association for .url which I tried according to original post? I tried change that to Firefox, it gave a popup error, although different from when IExplorer is default. But either program should work as default I presume? And neither does. –  bretddog Apr 26 '13 at 12:22
    
I can't answer what that reg entry is. I'm not qualified. This is where I need help. But maybe you didn't ask me.. –  bretddog Apr 26 '13 at 12:26
    
All I can say at this point is: It looks like you have some leftovers in your registry. Clean it with reg Cleaner then follow my advice above. –  Buscar웃 Apr 26 '13 at 12:37
    
Ok, you mean like with ccleaner? –  bretddog Apr 26 '13 at 12:39

I recommend deleting and replacing the internet shortcut.

You can create a shortcut by right clicking on the desktop and select Shortcut.

the shortcut can either be a link or access to another program

share|improve this answer
    
It's not one shortcut, it's any shortcut. (Edited that from an to any, if that was confusing) –  bretddog Apr 26 '13 at 11:04

This script from Autohotkey seems to solve it directly by repointing where the default browser is (assuming it's portable, I think, but it may do Autohotkey Script

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.