Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wrote a program in Turbo Basic in 1993 that uses the PLAY command. It works fine opening a DOS window in Windows XP and playing the different pitched PC beeps. However in Windows 7, although the DOS window opens and displays the message, at best it is silent and at worst makes a few buzzing noises and sometimes hangs with a continuous note.

share|improve this question
3  
there is no dos in win7 :-) it's a "command prompt". Did you attempt to set it up for compatability? Right click the executable, go to the Compatability tab, and test a bunch of settings, and none of them will fix it, but it is worth a try. Is this a 64bit win7? –  Psycogeek Apr 26 '13 at 13:56

2 Answers 2

The beep API has been replaced in 64 bit editions of windows.

There is not much you can do to fix it, I have found through some experementing on my own that if you have no sound device installed it will fall back to the old PC speaker but you must have no sound devices installed in windows for this to work.

share|improve this answer
    
I vaguely remember reading somewhere that you can copy some files from an XP machine to 7 to get the functionality back... but I might be thinking of something else. Now that I am thinking about it, I think it was related to the DOS console beep, not sound in general... –  Keltari Apr 26 '13 at 15:40
    
This is a brilliant answer! –  Dave Apr 29 '13 at 7:43

My suggestion is you download a DOS program, the most popular I know of is DosBox and then run it as you used to!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.