Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Update: jump to the end of this question for the happy conclusion to this epic tale.


Note: I have IIS7 installed locally for web development.

This is what happens in my browser for random sites:

local web server

That is, a totally gibberish URL resolves to my localhost webserver. (All gibberish hosts do this--not just the one.)

This affects several of us in the company...but doesn't appear to affect all of us.

Here's the troubleshooting I've done so far:

  1. Checked my proxy settings - all clear
  2. Checked my hosts file - all clear
  3. Checked other browsers - it affects Chrome, Chrome Incognito, and Internet Explorer
  4. Ping/nslookup google and a random gibberish url:

    C:\Users\mharen>ping google.com

    Pinging google.com [74.125.228.98] with 32 bytes of data: Reply from 74.125.228.98: bytes=32 time=21ms TTL=51 ...

    C:\Users\mharen>nslookup google.com

    Server: (my dns) Address: 192.168.48.20

    Non-authoritative answer: Name: google.com Addresses: 2607:f8b0:4004:803::100e 74.125.228.100 ... 74.125.228.98

    C:\Users\mharen>ping somerandomsitesoaosoasda.com

    Ping request could not find host somerandomsitesoaosoasda.com. Please check the name and try again.

    C:\Users\mharen>nslookup somerandomsitesoaosoasda.com

    Server: (my dns) Address: 192.168.48.20
    * (my dns) can't find somerandomsitesoaosoasda.com: Non-existent domain

So that is what I would expect--good domains resolve, bad ones don't. So what in the world is screwing with my browser?

Any troubleshooting tips?

Update: ipconfig /displaydns

I just ran ipconfig /displaydns, which is pretty spiffy. Here's the interesting entry among a few dozen good records:

somerandomsitesoaosoasda.com
----------------------------------------
Name does not exist.

Update: Try new DNS servers:

In case pinging and nslooking wasn't enough to rule out my DNS servers, I followed Joshua's suggestion and switched over to Google's DNS. Unfortunately, the problem persisted.

Update: Fixed!

With help from the answer Joshua linked to, we determined that this command fixed the issue:

netsh winsock reset all

We ran this command before and after to see what it changed:

netsh winsock show catalog

Which revealed 10 entries like this were missing after the reset command was run:

Winsock Catalog Provider Entry
------------------------------------------------------
Entry Type:                         Layered Chain Entry
Description:                        BarracudaWSA over [MSAFD Tcpip [TCP/IP]]
Provider ID:                        {FECB95F8-BE34-4B8A-A1ED-16A678A8ACC6}
Provider Path:                      C:\windows\system32\BarracudaWSA64.dll
Catalog Entry ID:                   1017
Version:                            2
Address Family:                     2
Max Address Length:                 16
Min Address Length:                 16
Socket Type:                        1
Protocol:                           6
Service Flags:                      0x66
Protocol Chain Length:              2
Protocol Chain: 1016 : 1001

BarracudaWSA (Web Security Agent), it turns out, is a web filter installed by IT.

share|improve this question
    
I like Joshua's suggestion of ensuring it's YOUR localhost. Just edit C:\inetpub\wwwroot\iisstart.htm, if you don't want to disable your local IIS. –  xdumaine Apr 26 '13 at 15:43
    
@roviuser it's definitely my localhost. Good idea, though. –  Michael Haren Apr 26 '13 at 15:54

1 Answer 1

up vote 5 down vote accepted

Some ideas:

  • Are you SURE this is your localhost? Or... could it be that your DNS server is also running IIS and serving that default page for domains that do not resolve? Have you tried disabling your local IIS server?
  • Also blaming the DNS server, could it be that the DNS server returns 127.0.0.1 for non-existent domains?
  • Have you checked the local routes to see if anything odd appears? To view, pull up a command prompt and enter "route print".

How to test whether the DNS server is misconfigured:

  1. Open your local network adapter settings, and change your IPv4 and / or IPv6 DNS settings from "Obtain DNS server address automatically" to "Use the following DNS server addresses".

  2. Set the Preferred and Alternate to something else, such as Google Public DNS or Neustar's DNS Advantage:

  3. Try the bad domains again.


For the win: This guy's answer (seems to have gotten you to the right place): All my browsers suddenly don't support Javascript files anymore?

Congrats. Glad I could at least help steer you in the right direction :)

share|improve this answer
1  
I'm experiencing the same issue - we've determined it is localhost by renaming welcome.png in C:\inetpub\wwwroot. The page displays a broken image as expected. Disabling IIS results in a 404 error, re-enabling displays the splash screen. –  Pwninstein Apr 26 '13 at 15:51
    
@Joshua, it is definitely my localhost. I'm not sure how else to exclude your other idea-- I did pings and nslookups to random hosts and they do not resolve. I'm open to other ideas, though. Thanks! –  Michael Haren Apr 26 '13 at 15:55
    
@MichaelHaren I updated my answer with How... –  Joshua Apr 26 '13 at 16:04
1  
Thanks, @Joshua, I switched over to Google's DNS and the problem persisted. That's helpful in ruling out my office's and ISP's DNS. –  Michael Haren Apr 26 '13 at 16:10
2  
Hmmm... check out the answer on this question: superuser.com/questions/338320/… –  Joshua Apr 26 '13 at 21:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.