Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes when several system sounds play at once, Windows 7 will forcibly lower their volume even though I have disabled automatic volume reduction in Sound -> Communications.

1

In my case, I have sounds set to play when a program opens or closes. Whenever a UAC prompt appears it often causes the issue because it plays program start, UAC notification, and program stop sounds all at once. I never use any kind of audio communication on my computer so I can only guess this is something else. I have seen this problem occasionally for years, across different hardware. Is there any known tweak/hack for stopping this or any confirmation that it can't be fixed?

share|improve this question
    
If UAC is causing this, why not disable UAC? That's the first thing I disable on a fresh install. I know its not a fix, but a possible workaround. –  Tillman32 Apr 26 '13 at 23:13
4  
Don't disable UAC - instead set it to not black out the screen. –  Nathan Adams Apr 26 '13 at 23:18
4  
Reducing security is not an option. –  DBN Apr 26 '13 at 23:53
    
Perhaps it's detecting all the loud sounds being played simultaneously and limiting the volume, although are you sure Windows is responsible and not your audio driver/software? Some things to check out: under Audio Mixer / Speaker Properties / Enhancements, do you have Loudness Equalization turned on? Also, is Skype running by any chance? –  Karan Apr 27 '13 at 2:19
    
My primary audio device (sound card) doesn't have an enhancements tab and my other one (motherboard) doesn't have any enhancements enabled. Skype is not installed. (I have witnessed this problem before I had the sound card.) –  DBN Apr 30 '13 at 7:27
add comment

2 Answers

up vote 2 down vote accepted

I found a way to fix the UAC issue specifically:

  1. Open the Registry Editor. (See here for information if you don't know how to edit the registry.)
  2. Open the HKEY_USERS key. (Keys have folder icons by them.)
  3. Open the first key in the list and go to Software\Microsoft\Multimedia\Audio. The Multimedia and Audio keys probably won't exist so create them by right clicking on the key to place them in and selecting New -> Key.
  4. Make sure the Audio key is selected and check the right pane to see if UserDuckingPreference exists. If not, create it by right clicking in the pane and selecting New -> DWORD.
  5. Double-click on UserDuckingPreference and set its value to 3. (The Hexa/decimal option doesn't matter in this case.)
  6. Go back up to HKEY_USERS and close the keys you had open under it, then start over from step 3 for each of the other top keys in HKEY_USERS.

This will force the "Do nothing" setting on every user account in the system, including the special account that is used for the UAC dim screen.

This probably fixes other potential issues with special screens like the logon screen.

share|improve this answer
    
This was the only tip that actually fixed the Problem. If the volume is still wrong. You might want to try doing this: superuser.com/questions/384472/… But again for every user in your registry, where the key exists. –  clst Dec 23 '13 at 13:38
add comment

Tried the above options, but, still they didn't work. I noticed there were a lot of processes running in the background opened the Task Manager.

In my case, this fixed the issue: 1) Run msconfig , 2) Click the "Services" tab, 3) Check the "Hide all Microsoft services" check box, 4) Click the "Disable all" button, 5) Click the "Apply" button, 6) Click the "Ok" button, 7) Typically, it asks you to "Restart" your computer, so, select "Restart".

share|improve this answer
1  
This is an extremely bad idea as it will disable all system services installed (except for the Microsoft ones). You could potentially be disabling your anti-virus. I also highly doubt that this will fix the issue. –  Roald van Doorn Jun 27 at 7:57
    
I stand corrected. You are right. Then, might as well disable only the non-Microsoft audio related services. I'm using MS Security Essentials, by the way. Thank you. –  user339144 Jun 27 at 8:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.