Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A couple days ago, without realizing it, I installed and configured Ubuntu 12.10 only to find out that 13.04 was going to be/has been released.

I tried all the usual tricks to get the update, from update-manager -d to apt-get update && sudo apt-get dist-upgrade this is of course after doing sudo -i.

I have even tried the normal way, through the update manager - nope. My system is all up to date yet I am running 12.10.

I have a work machine that was upgraded yesterday via the update-manager command.


share|improve this question
What makes you think you are still running 12.10? What was the output of the commands you tried? What do you mean by "nope"? What is the output of lsb_release -r? – terdon Apr 27 '13 at 15:49
up vote 1 down vote accepted

Try this:

sudo apt-get update
sudo apt-get install update-manager-core
sudo do-release-upgrade

Please backup your data before you do that - whenever I did this I almost ALWAYS had issues. It was never anything critical but usually it was like an icon package that didn't get installed.

share|improve this answer

Im taking a guess here as I dont use Ububtu. I had a similar issue with Mint a while ago, where there was no upgrade from 13 to 14, they wanted you to do a fresh install. There were some workarounds, but I figured better safe than sorry. I did come across this article for Ubuntu, thay may be useful to you. Perhaps following the steps will allow you to upgrade. It shows how to set the OS upgrade notification.

share|improve this answer

Your first mistake. apt-get dist-upgrade does not upgrade the distribution. Have a look at this page from ubuntu:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .