Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The machine runs Windows 7 Home edition. I'm trying to use rsync to backup files to a linux box. The rsync command runs fine in cygwin. I resolved an earlier error by running the cygwin terminal as Administrator. Here's what I see:

Helen@Helen-PC ~
$ cron-config
Cron is already installed as a service under account .\Helen.
Do you want to remove or reinstall it? (yes/no) no
Running cron_diagnose ...
... no problem found.

cygrunsrv: Error starting a service: StartService:  Win32 error 1069:
The service did not start due to a logon failure.

Here are what I'm guessing are the most important bits from cronbug.txt:

Current version
-rwxr-xr-x 1 Helen None 5304 Feb 15  2010 /usr/share/doc/Cygwin/cron-4.1-59.README

Running crons:
None

Crontabs:
-rw-r----- 1 Helen root 431 Apr 27 09:09 /var/cron/tabs/Helen

Service             : cron
Display name        : Cron daemon
Current State       : Stopped
Command             : /usr/sbin/cron -n
stdin path          : /dev/null
stdout path         : /var/log/cron.log
stderr path         : /var/log/cron.log
Environment         : CYGWIN=" " 
Process Type        : Own Process
Startup             : Automatic
Account             : .\Helen

/var/log/cron.log doesn't exists but Helen owns the directory. I get the same error message when I try to start cron directly, e.g. net start cron. Any help is appreciated!

share|improve this question

I realize now what I did wrong. When I originally ran cron-config, I entered the wrong password for the Helen account. I didn't realize this password was saved in some way for starting the daemon.

To fix, I ran cron-config, answered yes to Do you want to remove or reinstall it?, then answered yes to the install and start questions. Output of cron-config included: The cron daemon is now running. and I confirmed by setting my rsync command to run a few minutes in the future. The rsync happened as expected.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .