Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just updated Samba on my Arch Linux machine to 4.0.5 and now it is asking for password even when it shouldn't, and didn't do before the update.

This is my smb.conf: https://gist.github.com/eaxexe/07db0488b1d04e556e61

Can anyone tell me what is wrong? Thanks! :)

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The security = share mode was deprecated since Samba 3.6, and has been removed from Samba code in February 2012 (commit d7bb961859a350):

s3-auth: Remove security=share (depricated since 3.6).

This patch removes security=share, which Samba implemented by matching
the per-share password provided by the client in the Tree Connect with
a selection of usernames supplied by the client, the smb.conf or
guessed from the environment.

The rationale for the removal is that for the bulk of security=share
users, we just we need a very simple way to run a 'trust the network'
Samba server, where users mark shares as guest ok.  This is still
supported, and the smb.conf options are documented at
https://wiki.samba.org/index.php/Public_Samba_Server

At the same time, this closes the door on one of the most arcane areas
of Samba authentication.
share|improve this answer
    
Thanks :) But outcomment the entire line doesn't fix the issue :( –  Eax Apr 27 '13 at 22:09
1  
It's not going to. You need to configure Samba to accept guest connections in user mode. –  grawity Apr 28 '13 at 8:30
    
I must admit that I honestly don't know where to do that. Can you point me towards where I do that? Thanks! –  Eax Apr 28 '13 at 9:53
1  
See the "Public Samba Server" link that's in the commit message. –  grawity Apr 28 '13 at 10:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.