Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My workstation has been just updated to CentOS 5.7 from CentOS 4.x. This makes Beyond Compare breaks because it uses Qt3, not Qt4 which is being used by the CenOS 5.7 KDE environment. The Beyond Compare readme (see below) says to configure Qt3 manually to fix this issue. Though the qtconfig I executed seems to be for Qt4. How should I manually configure Qt3? I don't have root permission, so not sure how to install Qt3 via RPM.


README:
Beyond Compare for Linux supports the theme and styling features for Qt3. KDE, a popular desktop environment, allows for customization of Qt's styling options. However, most current KDE distros use Qt4 which does not configure Qt3 applications automatically. If your distro is Qt4 based you will need to use qtconfig for qt3 to change the styling. (how?)



Error message when launching Beyond Compare via command line mode.

Conflict in /usr/lib64/kde3/plugins/styles/dotnet.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/kthemestyle.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/light.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/plastik.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/scheck.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/highcolor.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib64/kde3/plugins/styles/keramik.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-canvas no-network no-opengl no-sql no-table no-xml", got "x86_64 Linux g++-3.* full-config".
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.