Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to add a new item for creating a new .lua script in the "new" context menu.

I tried following this guide but it just doesn't show up on the context menu at all. I also tried doing it manually, by adding a new key to .lua named ShellNew, and creating a new string value called "NullFile" with no value attached to it. I can delete the ShellNew folders of other file extensions and they immediately disappear from the context menu just I would expect, but adding new items don't work. Any ideas?

The regedit version I have is 6.1, and most of the guides I've been referring to are for version 5.0

share|improve this question
up vote 4 down vote accepted

Try the following instead:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lua]
@="LuaScript"

[HKEY_CLASSES_ROOT\.lua\ShellNew]
"NullFile"=""

[HKEY_CLASSES_ROOT\LuaScript]
@="Lua Script File"

The key to finding these was to essentially follow what Windows has for text files, or what it calls "Text Document." A few reboots later, I got the needed "new Lua script file" function.

share|improve this answer
    
It worked! After looking over it I think I understand the process better now, thanks! :) – David Gentry Apr 28 '13 at 10:57

.lua should have as (Default) value empty or (value not set), if it has an association you could create a sub key with the name of the association and then in that sub key create the ShellNew. Other variables which can influence workings are Content Type and PerceivedType, if these are set these could disrupt normal operations, as described in that tutorial.

For ex. for .docx I have as (default) 'Word.Document.12', by default it has no ShellNew but a sub key called Word.Document.12 and in that there's the ShellNew.

If not, try to refresh or close explorer and restart it from task manager. Reg versions are not relevant, they merely come with the OS version.

share|improve this answer

Users of Keynote (by Tranglos, but this may also apply to Pradov's NF versions) trying to get the .knt extension in the 'New' context menu should first go into Keynote's options and check the box that registers the extension (even if the icon is already set and you can click to open, believe it or not: you will still need to do this).
Do not try associating .knt in Explorer's Folder Options, as this does not make all the necessary key changes and so won't do the trick.
Then, you need to create a template and run the reg file (or edit the keys manually) as explained here.
A template is necessary, as otherwise the created new .knt file does not open, as it won't contain the settings it needs for loading. It may take a few minutes before the registry changes take effect! [Couldn't post this on the linked page, this seems the next best place, I'm sure Keynote users will find it here :-)]

share|improve this answer
2  
Please do not vandalize your own answers. You should either delete the answer or leave and improve the answer. Your answer is in the review queue and likely will be deleted, this answer because of its score, will still count against your ability to post new answers when that happens. – Ramhound Nov 18 '15 at 14:00
    
Rolled back to the previous revision. – bwDraco Nov 18 '15 at 21:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.