Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two programs that rely on some .dll files. (Wikidpad and Microsoft WebMatrix2.)

I was using WikidPad for a while without issue. After I installed WebMatrix2 (which uses IIS Express, I guess), I got a bunch of "Bad Image" dialog boxes of the form:

WikidPad.exe - Bad Image

C:\Program Files (x86)\iis express\PHP\v5.3\icudt.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator of the software vendor for support.

After some struggling I checked the PATH variable and

C:\Program Files (x86)\iis express\PHP\v5.3\

was added to the path.

I deleted this part of the PATH variable, and WikidPad no longer showed the dialog boxes. However, WebMatrix2 no longer worked, for the same reason: Bad Image errors.

So one program needs the path to be there, and the other needs it to not be there.

How do I fix this?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Tried WikidPad 2.1_01 and it doesn't use icudt.dll as per Process Explorer reporting, so something must be wrong there. Did you use any plugins, PHP related?

It might also be that WikidPad uses 127.0.0.1 or localhost in its inner workings... which in turn would enter in conflict with IIS, which also uses 127.0.0.1. In this case the simple solution would be to manually stop IIS when you're done using it. The more complicated solution is to find out why PHP's settings are not read correctly... this is why you get that message, when you souldn't.

share|improve this answer
    
Thanks for your answer. I can't see IIS running anywhere. I looked in Control Panel -> Administrative Tools, as well as the process and service explorer in Task Manager. It doesn't seem to be running. I'll look at the php.ini file ... it looks like it was changed when I installed WebMatrix. –  JW. Apr 28 '13 at 5:07
    
Then run 'netstat -n -b' and see which process uses the localhost, just checked, WikidPad does use it on port 2000. –  emm980 Apr 28 '13 at 5:20
    
OK ... found WebMatrix started iisexpress.exe as a worker, but when I closed it, that process got killed automatically. Playing with the netstat command to try to see what you've seen. –  JW. Apr 28 '13 at 5:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.