Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two TP-Link router to build a home network with, both Wireless (WR841N and WR642G). I connected the WAN to the WR841, there is 2 desktop PC connected to it, works fine. I tried to add the second router (WR642G) this way:

  1. Reserved an IP for it in my MAIN router, the reserved address is 192.168.1.150 (my main dhcp range is 192.168.1.100-199).
  2. Booted up the second router, connected the 2 desktop PC to it and the first routers cable went to the WAN.
  3. The second has no bridge or other function like that, so I set the WAN settings to dynamic ip. This way it got the ip address 192.168.1.150
  4. I set the its LAN address to 192.168.2.1 and the DHCP range to 192.168.2.100-199. If I turn the DHCP off (at the second router), I can not reach it anymore.

This way there is internet access at all my PC -s, but the network not really working well. I can not reach (ping) a PC connected to the first router from the second router.

How should I disable the DHCP on the second router, so all the IP addresses are managed by the first router?

share|improve this question

I believe the second router should 'forward first router's dhcp' (known as DHCP forwarding). But then I assume you would get IPs from the first network (192.168.1.x).

So you should configure on the first router a second IP pool (DHCP setting) wich will be used by machines connected to the second router. This pool would deliver IPs in the network 192.168.2.0/24.

share|improve this answer
    
You think right, I have done that. I needed the first router to manage the network completely and the second to transmit data. – pokemarine Apr 28 '13 at 22:11
up vote 0 down vote accepted

I solved it this way:

The first router's configuration stayed the same way. The second: Don't use the WAN port and turn DHCP off, this way the 1st router going to pass the IPs to all PC.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .